1

I installed supervisor using pip on my debian 7 installation. I then grabbed this file and moved it here: /etc/init.d/supervisord

https://github.com/Supervisor/initscripts/blob/master/debian-norrgard

Then I ran:

chmod +x /etc/init.d/supervisord
update-rc.d supervisord defaults

However, when I run the command supervisord the program starts fine, but when I run:

service supervisord start

I get no error or message, but supervisor doesn't actually start. How can I find out what is going on and why it isn't starting?

1

I installed supervisor using pip on my debian 7 installation.

Why would you go and do a thing like that?!? :)

There's a perfectly good supervisor package in debian's apt repo. Why not use that? That package has been well-vetted, and is configured to work seamlessly with your specific linux distro and version - none of this mucking around required.

A general rule of linuxing is this: always use packages from your OS's package repo, unless requirements dictate otherwise.

  • Thank you for the reply. The apt-get Debian one is very outdated and supervisor suggests installing the up to date version so I was aprehensive about that – Jimmy Mar 14 '14 at 23:09
  • Have you tried it? There hasn't been a whole lot of change in supervisor, so it's likely the older version will work just fine for you. – EEAA Mar 14 '14 at 23:11
  • 1
    The Debian apt-get version of supervisor is over 4 years old with quite a few changes I don't really want to use it – Jimmy Mar 14 '14 at 23:18
  • The debian supervisor version is 3.0 which doesn't support logging to syslog nor stop/killasgroup. I guess that is good enough reason to not use the debian package. – tobltobs Mar 22 '17 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.