-2

After updating python version libc6 was broken on my Ubuntu 12.04

I have libc6 2.18-4 and it broken.

It was installed from unstable repo. From precise repo I see 2.15.0 version of libc6. But if I try to force it, I see long list of "To be removed" packages. How can I prevent this deletion and fix my libc6?

Error message:

dpkg: dependency problems prevent configuration of locales:
 libc6:i386 (2.18-4) breaks locales (<< 2.18) and is installed.
  Version of locales to be configured is 2.13+git20120306-3.
 libc6 (2.18-4) breaks locales (<< 2.18) and is installed.
  Version of locales to be configured is 2.13+git20120306-3.
dpkg: error processing locales (--configure):
 dependency problems - leaving unconfigured
8
  • What command did you run to update Python? What error message is telling you that libc6 is broken? What was installed from the unstable repo and which repo was it? It's probably not worth the time to figure all that out. Just re-image the machine and restore the data from backup.
    – Ladadadada
    Mar 15, 2014 at 9:32
  • I just opened synaptic and updated python version. How I can get the error message? I haven't a backup...
    – asiniy
    Mar 15, 2014 at 9:44
  • Synaptic? You have a windowing system on this server? And no backups? Is your system still usable enough to make a backup? If so, do that first.
    – Ladadadada
    Mar 15, 2014 at 12:02
  • Added an edit, waiting for response
    – asiniy
    Mar 16, 2014 at 4:35
  • @Ladadadada, I'm waiting
    – asiniy
    Mar 18, 2014 at 17:52

1 Answer 1

2

It seems like libc6 library depends on 2.13+git20120306-3. But I can't repair libc6 without installing a locales 2.18-4. So, I just replaced locales with the locales-all 2.18-4 and removed the annoting locales library.

Problem solved! There isn't a conflict now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.