1

I have a remote office that I am hooking up to our corporate network and this particular site has a centurylink adsl2+ router that I need to negotiate an rfc 1483 via DHCP connection across. The dsl modem is in bridged mode and it is connected to the outside interface on the ASA. I need to configure the ASA to negotiate with the ISP to bring the interface up and pass traffic.

RFC 1483 via DHCP multiplex set llc based Bridged mode vpi:8 VCI:35 encapsulation ADSL2+

Any ideas on what the best ways to set this up are?

bumped to the homepage by Community 19 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • Whilst I have no idea myself, this guy seems to have done a bit of homework. Apparently it is not solved by PPPoE config, but what do I know. Perhaps you find something of use: farside.org.uk/200903/ipoeoatm – ErikE Mar 16 '14 at 6:29
  • Erik, that is an excellent little article and it totally covers what I need to do. I have to encapsulate my IP within ethernet frames as they go through my outside interface and land on the DSL modem. – user13846 Mar 16 '14 at 16:45
  • That's what the DSL modem is doing. – Bill Weiss Mar 17 '14 at 2:44
  • I'm glad it was of use, user13846. If you wish to formulate your own answer with your specific solution I'll upvote. – ErikE Mar 18 '14 at 7:33
  • So when I place the device in transparent bridging mode it will only pull an IP when I have the modem set to connect to the ISP first. So there is a form of encapsulation that the cisco needs to package the IP packets in for it to properly go across the wire. When I let the modem handle the encapsulation, the connection is really slow. Painfully slow however it seems to pass traffic. There are plenty of folks who were able to get this working with PPPoE and a username and password. Unfortunately I have to use DHCP. Running out of ideas here. – user13846 Mar 22 '14 at 16:21
0
interface (whatever)
 nameif outside
 pppoe client vpdn group CHN
 ip address pppoe
!
mtu outside 1492
!
vpdn group CHN request dialout pppoe
vpdn group CHN localname (your username)
vpdn group CHN ppp authentication pap (or whatever you need)
vpdn username (your username) (your password)

Reference: Cisco "PIX/ASA: PPPoE Client Configuration Example" docs

  • You may want to suffix the ip address pppoe with setroute to say, well, set the route with that pppoe connection. Also, "CHN" is an arbitrary name as far as I can tell, I'm just using what's in the docs – Bill Weiss Mar 16 '14 at 1:11
  • This ISP does not use a username or password. It is supposed to pull the ip address and negotiate the connection automatically. I looked around online to see if there were any specific configurations like this and did not see anything that was a perfect match. – user13846 Mar 16 '14 at 2:07
  • Huh. You use PPPoE but not auth? Could you try just ip address pppoe on the appropriate interface and not the rest of it? – Bill Weiss Mar 16 '14 at 12:25
  • Reading that Cisco site, there's a comment above the vpdn group CHN ppp authentication pap line that says If your ISP requires authentication, select an authentication protocol. I think you can leave it out and it'll still work. – Bill Weiss Mar 16 '14 at 12:26
  • You could also (sorry about all the comments at once) try just turning on DHCP and see if it happens. I doubt it, but it's possible? What are their suggested settings for the DSL modem? – Bill Weiss Mar 16 '14 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.