I have installed MySQL 5.6.16 on Debain 7.4.

But i encountered problems with starting mysql, where every time i start mysql i get this error:

The server quit without updating PID file (/var/run/mysqld/mysqld.pid). ... failed!

After a lot of googling i saw that i should rename/move my.cnf file from /etc/mysql to see if mysql starts. And it start and stop without problems, but if try to connect to database with my software i get this:

Caught database OperationalError: (2002, "Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)")

Then i tried adding/deleting everything from /var/run/mysqld and adding users and groups but nothing changes.

And i can't find any log files from mysql even setting them up in my.cnf.

This is my.cnf file from /etc/mysql Pastebin

  • How you installed Mysql on yuor Debian via apt-get or you compiled it? – Abhishek Anand Amralkar Mar 16 '14 at 15:29
  • @AbhishekAnandAmralkar i complied it. – Test Mar 16 '14 at 16:13
  • Launch the start script in debug mode and see where/why it fails. bash -x /etc/init.d/mysql start – akuzminsky Mar 16 '14 at 19:20
  • This is what i get in ouput: pastebin.com/DDw3VzNv – Test Mar 16 '14 at 22:29
  • Solved by installing 5.5 from debian repository. I think there is a bug in 5.6.16 – Test Mar 17 '14 at 21:31

I encountered a similar problem. In my case, it was a missing PID file. So I had to manually kill the MySQL process and then restart it. The PID file was then created when I restarted MySQL.

Here's a great post that may help you: http://linuxadministrator.pro/blog/?p=225

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.