This issue is related to Windows Update forcing a restart when the last session logs off Server 2003. Updates have been installed and a restart is pending. Obviously this is problematic if the last session is logged off during the day. The server is subject to a network wide GPO. Is there any way to prevent this behaviour?

I have read many articles on the matter, but most suggest modifying a setting that is not available i.e. 'No auto-restart for scheduled Automatic Updates installations'. The setting I have is: 'No auto-restart with logged on users for scheduled Automatic Updates installations', which is obviously not what I'm looking for.

As far as I can tell there is no way around this behaviour. I could perhaps remove the servers from the network-wide GP, and either deal with updates manually (not desirable) or create a GPO for the servers and use Option 3 to download but not install the updates, which again is not ideal. I am happy with the auto-install aspect, but want to be able to prevent the restart behaviour described above and have it restart at a set time.


EDIT: Here's a case of me typing out an answer and then coming back to it years later to realize I didn't read the question properly.

The real answer is...you CAN'T.

Some updates require a reboot, and as such MS in their wisdom decided that if nobody was logged on to the "computer" then it must be OK to reboot it...including a server.

So what options do you have? Pretty simple...don't set automatic updates on a server. Set it to "Download updates but let me choose whether to install them" if you are using WSUS on a server. Use a separate GPO for servers compared to workstations.

This is ideal anyway, since you really should have your servers on a specific maintenance schedule that you control where you can be connected to the server, install the updates, reboot, and make sure all is well.

For those servers that aren't critical and you believe WSUS and Windows Update can handle things well enough, just set it to install updates automatically at something like 2am or similar and auto-reboot then.

Also worth reading: Reboot behavior - WSUS Clients



I'm not sure why you wouldn't have the proper GPO setting. Are you trying to set the GPO settings from a 2003 machine using GPMC?

The setting should definitely be available as shown here: Configure Automatic Updates by Using Group Policy

Specifically as you mention:

To inhibit auto-restart for scheduled Automatic Update installation options:

  1. In Group Policy Object Editor, expand Computer Configuration, expand Administrative Templates, expand Windows Components, and then click Windows Update.
  2. In the details pane, click No auto-restart for scheduled Automatic Update installation options, and set the option.
  3. Click OK.

That really is what you are looking for. If you don't see it, something is amiss.

However, I will state that if you have a fairly small number of servers, my recommendation is to use the "download but not install updates". This allows you to custom pick and choose the updates for the individual server(s) as well as do it on a custom maintenance plan that you employ and can then manually reboot the server and watch it come back online.

Granted, that means "more manual labor" and some shops simply don't want to do this, but if you have the means to do so it's not difficult to employ.

  • I am using GMPC on a Windows 7 PC, do you think this might be the problem? The templates (ADMX) are loaded from a central store. – user213158 Mar 18 '14 at 14:22
  • The options are too numerous to type out, if only there was a way to attach a screenshot! But essentially where 'No auto-restart for scheduled Automatic Updates installations' should sit it is replaced by 'No auto-restart with logged on users for scheduled Automatic Updates installations'. – user213158 Mar 18 '14 at 15:17
  • I have uploaded a screenshot to the thread I have on SpiceWorks on the problem link – user213158 Mar 18 '14 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.