I am having issues replicating AD from one DC to another. Both servers are Windows Server 2008 R2 SP1. I have used the GUI option in sites and service to force replication. I have also tried repadmin, and ntsdutil.

The command for repadmin that I tried:

repadmin /replicate mars zeus dc=CS,dc=local

I get the error when I try repadmin:

Repadmin can't connect to a "home server", because of the following error. Try specifying a different home server with /homeserver:[dns name]

I have downloaded the Active Directory Replication Status Tool from [here]: I have recived the following error after I ran the replication status.1

AD Tool Error AD Tool Error 2

I have created a youtube video, better explaining my issues: The video here

I was hoping someone could help me replicate my two DC with AD. I am really not sure what to do next, or what else to try.

  • 1
    Repadmin can't connect to a "home server", because of the following error. What is that error? – Jeremy Lin Mar 18 '14 at 17:05
  • @JeremyLin fixing it now, and set the video not be private. Thanks – nate Mar 18 '14 at 17:13
  • I'm too busy to think about your question right now, but upvote for the Youtube video. Never seen that before. – Ryan Ries Mar 18 '14 at 20:31
  • Run dcdiag.exe on both servers? Also I see there is a third-party filter driver on your NICs - is this a recent addition (LiveQoS NDIS Filter Driver)? – BlueCompute Mar 19 '14 at 11:20
  • @BlueCompute Could you put that in a answer instead of a comment please. – nate Mar 19 '14 at 14:09

It probably is a recent addition of LiveQoS NDIS Filter Driver.

Uncheck the filter on your IPv4 NIC and reboot your servers to be sure. I bet that fixes your problem.

| improve this answer | |

Its not clear what the immediate cause of your issues is, but one thing that jumps out at me is the presence of a 'NDIS Filter Driver' on both your servers' NICs. These drivers are often installed by AV, but in your case seem to be from some sort of QoS software. Filter drivers are a common cause of network issues in Windows.

I'd try disabling or uninstalling the LiveQoS NDIS Filter Driver, rebooting and testing again. Also you don't say whether you've run dcdiag.exe, which would be one of the first things I'd run when troubleshooting AD. Consider running that and posting any errors here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.