0

I need some help getting ngnix installed on Suse Linux Enterprise 11. This is my first time trying to do this so I am likely missing something basic. Thus far I have:

wget http://nginx.org/packages/opensuse/12.1/SRPMS/nginx-1.4.7-1opensuse12.1.ngx.src.rpm

the under sudo I ran

yast nginx-1.4.7-1opensuse12.1.ngx.src.rpm

This installed several files under /usr/src/packages/SOURCES/

but, for example, when I run chkconfig --add ngnix I get an ngnix: unknown service error.

What steps did I miss during the install

(I was able to get this all up and running on the regular version of Suse Linux 13.1 but the differences between that and Enterprise are confusing me...)

2

You've installed the source package rather than the compiled version.

Instead, try

http://nginx.org/packages/opensuse/12.1/x86_64/RPMS/nginx-debug-1.4.7-1opensuse12.1.ngx.x86_64.rpm`

or, for a 32-bit install,

http://nginx.org/packages/opensuse/12.1/i586/RPMS/nginx-debug-1.4.7-1opensuse12.1.ngx.i586.rpm
1
  • That makes sense, thanks. I'm giving it a try now but running into so many dependency issues... – RedRaven Mar 19 '14 at 16:54
0

nginx.org currently provide binaries for opensuse 12.1 and sles 12

The instructions here are for SLES 12, but here they are repeated and modified for opensuse 12.1

sudo zypper addrepo -G -t yum -c 'http://nginx.org/packages/mainline/opensuse/12.1' nginx
sudo zypper in nginx

Or you can add opensuse build binaries.
But in your question you ask about SLES 11, but I saw that you were installing opensuse12.1 src packages. This is a cause of your problem, you cannot do this, or if you can it's the wrong way SLES != opensuse, but also if you are using open use, you'd prefer opensuse 11 for SLES 11.

Goto to

https://software.opensuse.org/package/nginx

Click on the version of SLES 11 you are using, if it's SP4 then the main repo 'server:http' is not configured. If you are on SP3 then clicking on https://build.opensuse.org/package/show?project=server%3Ahttp&package=nginx shows that even though SP3 is configured it isn't currently building as GeoIP is unresolved.

But you want the legacy version of nginx 1.4.7, rather than the current stable 1.8.0

You can look through the builds and see if you can find a matching SLES 11 SPx and nginx version you want.

Then I would add it as a repo, here's how I added nginx to SLES 12 (note osb_suse_servers_http is just the name I use for the repo)

sudo zypper ar http://download.opensuse.org/repositories/server:/http/SLE_12 osb_suse_servers_http
sudo zypper in nginx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.