1

My Windows Server 2008 should be configured to work as a DHCP Server in the Network. Therefore I setup the Role and configured everything.

I have downloaded a tiny tool, that can show DHCP-Offers on the Network. When executing it, i receive:

Packet from 192.168.100.5 
 Offered IP 192.168.100.202 
 Subnet Mask 255.255.255.0
 Renew Due in 345600 Seconds
 Lease Length 691200 Seconds
-------------------------

So this seems to work fine. However if I setup my network card to receive an IP from DHCP, it simple does not receive anything. Windows (Client) then picks up its default "No-DHCP-Available" Adress like "169.254.21.222 (Preferred)"

Service is Running, IPs are "offered", Also Login-Data for Dynamic DNS Update (DHCP == DC) is configured.

Windows Server Logs show nothing. Any Idea how I could debug this best?

edit: The DHCP is authorized on the Domain as well.


UPDATE 1: Wireshark:

I downloaded Wireshark for the Server and for the Client. Started it, and tried to /release, /renew IP-Adress... Nothing was logged (used filter (bootp.option.type == 53)) - Neither on Server, nor on Client side.

So, I disabled DHCP on my Server, re-enabled it on my dedicated router (Fritz Box), rebooted the client, and finally could trace a request done by the client:

8328    7.052393000 192.168.100.29  192.168.100.2   DHCP    362 DHCP Request  - Transaction ID 0x51a0cafa
8329    7.054365000 192.168.100.2   192.168.100.29  DHCP    590 DHCP ACK      - Transaction ID 0x51a0cafa

So, the client seems to work well in terms of DHCP.

I Enabled DHCP on the Server again, and set up the client to use a dynamic IP, but using the DNS of my Server as the primary (and only) DNS-Server. Again, I get nothing. (And again no Wireshark Logs on any device)

I noticed, that when doing /release, /renew, the /renew always throws an error, when having the DHCP on the Server enabled. (An attempt was made to access a socket in a way forbidden by its access permissions.)

But this looks like a local error to me, not sure what it has to do with the presence (or absence) of any DHCP Server.


UPDATE 2: I now did the following: Using a Static IP Adress, I started Wireshark on the Server, and switched to a Automatic Configuration on the Client. It didn't receive a IP-Adress (using the default of 169.254.21.222. Again, no Wireshark logs on the server.

Then I used the same configuration, and used the DHCP-Finder-Tool. Now the Server logged several DHCP Discovery Entries from THAT IP-Adress.

779 55.354991000    169.254.21.222  255.255.255.255 DHCP    590 DHCP Discover - Transaction ID 0x9a020000
780 55.355668000    192.168.100.5   255.255.255.255 DHCP    342 DHCP Offer    - Transaction ID 0x9a020000

However the client did NOT receive a IP Adress. Also the tool did not show any response, as it does, when using it from a hardcoded IP-Adress from within the same subnet.


UPDATE 3: Now I am Confused: Just checked the Adressleases of the DHCP and noted, that ANY WLAN-Device out there has successfully leased an IP Adress. (Duration ~ 8days)

However, for my (wired) Clients it still fails... ?

https://abload.de/img/wifi1b3xf7.png

Wlan Clients Lease

Wlan Clients are connected through an AccessPoint, that is connected to the very same 24-port switch every wired client is...

Just connected my PC with a spare WLAN-USB-Dongle - Worked perfectly fine...

https://abload.de/img/wifi23ojcg.png

Questionalbe Client with Wifi-Connection

ps.: I am very very familar with server setups - but this blows my mind - Why would there be a distinction between WLAN and WIRED clients, when it comes down to DHCP ?!


After Rebooting (and multiple times en/disabling) the client('s network connection) it works...

Maybe there is a "Cache" layer, that delayes the access on "new" DHCP Servers... However, so far my local client is the only one out of 20 that has successfully requested an ip-adress... i'll leave it like that and check the status tomorrow.

  • 1
    Are the client machine and the DHCP server connected to the same physical segment? – joeqwerty Mar 19 '14 at 20:19
  • @joeqwerty I would Assume Yes. Line Up looks like PC <-> 8 port switch <-> 24 port switch <-> DHCP-Server (Server and 24 port are in the rack, 8 port is in this room. Physical connection is fine, when using a static ip adress on the client) – dognose Mar 19 '14 at 20:44
  • 1
    OK, here's what I would do: run a packet capture program (like Wireshark) on the server and the client and start a simultaneous capture. Then run ipconfig/release and ipconfig/renew on the client and look at the capture on both sides to get some idea of what's happening. You can filter the capture to show only DHCP related traffic and you should see the DORA process from both sides. – joeqwerty Mar 19 '14 at 20:47
  • Trying running wireshark from the client to see if you can see arp requests, its possible that your network is some how blocking it. – the dave Mar 19 '14 at 21:06
  • 1
    Check your switches, especially if they are manageable, and look for dhcp/bootp relay/forwarding settings and make sure they are set to go to the Windows server. – TheCleaner Mar 19 '14 at 21:45
0

It sounds like you need to setup a DHCP relay or a helper IP address on your managed switch that points to the DHCP server.

You might also have an issue with the physical wiring on that segment. Most routers can provide DHCP across the LAN ports and pass traffic up the WAN port. If DHCP is disabled, routers work like switches across their LAN ports. The 24 port switch should be moved off the WAN port onto a LAN port.

I'm not exactly sure of the specific models of switches/routers in your network or how they are designed so this might not apply to your specific situation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.