0

After having installed a software on my Windows 2003 terminal server, no user has been able to launch applications anymore.
When they log to the server via remote desktop, each icon they click produces the message "there is no application associated to this file". Even "My Computer" or other default links.

After a lot of research, I discovered that the:
HKEY_LOCAL_MACHINE\SOFTWARE\Classes(all the sub-entries)
miss the "users" item in the permissions ACLs (see the screenshot below).

Infact, administrators aren't affected by the problem and regular users that get included into local administrator groups work correctly again.

enter image description here

Then i discovered an even more worrying fact.
In order to do some test, i've tried to manually assing to one of these subfolter the access for a regular user, and it worked, e.g.:giving access to the "Folder" entry, the user gets access to the "My Computer" item
But if i try to remove it, the system says that i can't because it is inherited by the parent!

So the propagation from parent to sub-items seems to be corrupted here.
Any idea of a way to fix it?

  • Restore the server from backup? – joeqwerty Mar 19 '14 at 22:55
  • Of course, this is a solution. And something to fix the registry? – AgostinoX Mar 19 '14 at 23:35
  • Check the advanced Security options.... you can change inheritance there. – HopelessN00b Mar 20 '14 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.