0

I installed cacti on a separate user account, on a server running WHM/CPanel.

RRDTool and snmpwalk are both installed correctly and when running the poller.php through the user "cacti" (not root), I get the following:

cacti@cacti.com [~/www]# php poller.php
03/20/2014 09:09:04 AM - POLLER: Poller[0] NOTE: Poller Int: '300', Cron Int: '300', Time Since Last: '243', Max Runtime '298', Poller Runs: '1'
03/20/2014 09:09:04 AM - POLLER: Poller[0] DEBUG: About to Spawn a Remote Process [CMD: /usr/bin/php, ARGS: -q "/home/cacti/public_html/cmd.php" 0 1]
Waiting on 1 of 1 pollers.
03/20/2014 09:09:04 AM - POLLER: Poller[0] CACTI2RRD: /usr/bin/rrdtool update /home/cacti/public_html/rra/localhost_mem_buffers_3.rrd --template mem_buffers 1395331744:1426112
OK u:0.00 s:0.00 r:0.00
Waiting on 1 of 1 pollers.
03/20/2014 09:09:04 AM - POLLER: Poller[0] CACTI2RRD: /usr/bin/rrdtool update /home/cacti/public_html/rra/localhost_mem_swap_4.rrd --template mem_swap 1395331744:32764316
OK u:0.00 s:0.00 r:0.01
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
03/20/2014 09:09:04 AM - POLLER: Poller[0] Parsed MULTI output field '1min:0.12' [map 1min->load_1min]
03/20/2014 09:09:04 AM - POLLER: Poller[0] Parsed MULTI output field '5min:0.19' [map 5min->load_5min]
03/20/2014 09:09:04 AM - POLLER: Poller[0] Parsed MULTI output field '10min:0.15' [map 10min->load_15min]
03/20/2014 09:09:04 AM - POLLER: Poller[0] CACTI2RRD: /usr/bin/rrdtool update /home/cacti/public_html/rra/localhost_load_1min_5.rrd --template load_1min:load_5min:load_15min 1395331744:0.12:0.19:0.15
OK u:0.00 s:0.00 r:0.01
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
03/20/2014 09:09:04 AM - POLLER: Poller[0] CACTI2RRD: /usr/bin/rrdtool update /home/cacti/public_html/rra/localhost_users_6.rrd --template users 1395331744:1
OK u:0.00 s:0.00 r:0.02
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
Waiting on 1 of 1 pollers.
03/20/2014 09:09:04 AM - POLLER: Poller[0] CACTI2RRD: /usr/bin/rrdtool update /home/cacti/public_html/rra/localhost_proc_7.rrd --template proc 1395331744:332
OK u:0.00 s:0.00 r:0.05
03/20/2014 09:09:04 AM - SYSTEM STATS: Time:0.1727 Method:cmd.php Processes:1     Threads:N/A Hosts:2 HostsPerProcess:2 DataSources:5 RRDsProcessed:5
Loop  Time is: 0.18
Sleep Time is: 299.82
Total Time is: 0.18
cacti@cacti.com [~/www]#

I even set the permissions of the files to 777 and they get generated OK, but they are empty and show only "nan".

cacti@cacti.com [~/www/rra]# v
total 344
drwxrwxrwx  2 cacti cacti    4096 Mar 20 07:22 ./
drwxr-x--- 16 cacti nobody   4096 Mar 20 07:37 ../
-rwxr-xr-x  1 cacti cacti      33 Apr  3  2012 .htaccess*
-rwxrwxrwx  1 cacti cacti  141640 Mar 20 08:09 localhost_load_1min_5.rrd*
-rwxrwxrwx  1 cacti cacti   47992 Mar 20 08:09 localhost_mem_buffers_3.rrd*
-rwxrwxrwx  1 cacti cacti   47992 Mar 20 08:09 localhost_mem_swap_4.rrd*
-rwxrwxrwx  1 cacti cacti   47992 Mar 20 08:09 localhost_proc_7.rrd*
-rwxrwxrwx  1 cacti cacti   47992 Mar 20 08:09 localhost_users_6.rrd*
cacti@cacti.com [~/www/rra]#

Anyone know what could be wrong?

Update 1: I even tried removing all the files in the rra/ folder and running poller.php again with the user "cacti" (not root). The files were generated again but again show "nan".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.