3

I get the following when trying to install perl-Time-HiRes:

host1:user1 > sudo yum install perl-Time-HiRes
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-Time-HiRes.x86_64 4:1.9721-119.el6_1.1 will be installed
--> Processing Dependency: perl = 4:5.10.1-119.el6_1.1 for package: 4:perl-Time-HiRes-1.9721-119.el6_1.1.x86_64
--> Finished Dependency Resolution
Error: Package: 4:perl-Time-HiRes-1.9721-119.el6_1.1.x86_64 (rhel-6-6.2-server)
           Requires: perl = 4:5.10.1-119.el6_1.1
           Installed: 4:perl-5.10.1-129.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               perl = 4:5.10.1-129.el6
           Available: 4:perl-5.10.1-119.el6_1.1.x86_64 (rhel-6-6.2-server)
               perl = 4:5.10.1-119.el6_1.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I don't understand. It seems to be looking for perl-5.10.1-129? But the latest available is perl-5.10.1-119, as far as I can tell.

I have the EPEL repos enabled, though this package is from the repo rhel-6-6.2-server.

I am actually trying to install munin-node, but it fails on the same package.

6
  • 1
    It is looking for perl-5.10.1-119.el6_1.1. Note the trailing _1.1. Mar 20, 2014 at 16:55
  • Right, I didn't notice that. But I can't seem to upgrade perl to that. yum update perl says it is up to date. Mar 20, 2014 at 17:03
  • You should be using upgrade rather than update I suspect something is obsoleted. Mar 20, 2014 at 17:23
  • 1
    If you mean to be on RHEL 6.2 (bad idea) why did you install 6.4? Mar 21, 2014 at 0:44
  • @MichaelHampton good spot! Turns out I am actually on 6.4, but it was configured to use the 6.2 repos (guess a mistake when the server was built for me). Using the 6.4 repos worked fine. Thanks! Mar 21, 2014 at 11:23

2 Answers 2

3

This is really a comment but I don't have enough points...

I've seen similar problems when doing yum updates. (and it is yum update not yum upgrade).

Usually, this is easily resolved by doing a "yum update ", i.e. "yum update perl" then, if that succeeds, do the "yum update perl-Time-HiRes"

0

As spotted by @MichaelHampton, I am actually using 6.4, but it was configured to use the 6.2 repos (guess a mistake when the server was built for me). Using the 6.4 repos worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.