I need to limit the number of sessions a USER can have on our rdp server.

I have the option to allow :

enter image description here

I found this setting to allow multiple connections:


but I wasn't sure that is what I need. It says:

You can configure the number of simultaneous remote connections that are allowed for a connection. Restricting the number of simultaneous remote connections can improve performance of the computer because fewer sessions are demanding system resources.

Which, to me, seems like an overall connection limit and not a user limit.

Is this the right setting? If not, what is the setting to only allow them 2 sessions per user?

If possible, I'd like this to be a GPO setting. I'm not sure if that is possible though.



A little background to my issues:

We have 3 virtual servers:

  1. Domain Controller - Windows 2008R2 x64
  2. SQL Server server - Windows
  3. 2008R2 x64 RDP server - Windows 2008 x32

The RDP server needs to run on a 32 bit operating system due to a legacy program that will not run on a 64 bit machine. (don't ask)

The RDP server has this application running through a terminal services published application.

All is working well but our customers are connecting 3 to 4 times and we want to prevent that. We don't want to overload the server. Besides, we told them they could use two sessions (application instances) per user.

I'm hoping there is a setting that we can say, 2 sessions per user so we don't have to make any programming changes.

  • I thought if a user was to log into the same account twice, it'd simply "log in" to the first session and boot the first session. At least, that's what happens to me. – Nathan C Mar 21 '14 at 14:07
  • Per the settings, see the printscreen, you can have multiple connections for the same user. Restrict each user to a single session option has to be unchecked for this to work. – JohnDoe Mar 21 '14 at 14:08
  • 1
    I'm curious what the actual larger issue is that you're trying to solve with this. Maybe there is a different way to handle it that you haven't considered. Can you elaborate a little more, please? – MDMarra Mar 24 '14 at 0:01
  • I'll update my question. – JohnDoe Mar 24 '14 at 0:05
  • To go along with what @MDMarra said, you still didn't answer why they would need to login more than once (maybe that's a limitation of your legacy app). But a few ways I could think to get around that would be to reenable 1 login. Then give them 2 user names. Jdoh1, Jdoh2; Sjohn1, Sjohn2; etc. That way there's no way they could login more than twice. – Nixphoe Mar 28 '14 at 19:01

What you have in your hand is for simultaneous rdp connection. But I don't think there is a setting which allows 2 sessions per user basis.

Please post the answer if I am wrong..

| improve this answer | |
  • starting to think you are right, I've not seen any evidence of there being such a setting. – JohnDoe Mar 24 '14 at 13:37
  • @JohnDoe: If so, Can you please accept my answer..?? – Vysakh Mar 25 '14 at 5:11

This should help:


It has on there that you can restrict it to 1 connection, but it does point you to the location of the GPO, so you should be able to play around with it there

| improve this answer | |
  • 2
    Summarize the link, it might dissapear at any moment. Besides, links make this site non-searchable, and thus much less useful. – vonbrand Mar 22 '14 at 23:41
  • 1
    This doesn't help. I am specifically asking to allow only 2 sessions per user. This option only turns on whether they can connect with more than one session or not, which you can see from the printscreen that I provided already. It does not have the option to set how many sessions they can connect with. It's 1 or many... I have this option disabled but users are getting in with 3+ sessions at a time now. I cannot lock them down to 1 session since we told them they would have 2 sessions. restrict user to only 2 sessions – JohnDoe Mar 23 '14 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.