5

While I was starting my vm I got this error

Microsoft Emulated IDE Controller Error(Instance ID 83F863B-8DCA-9EDA-2CA8B33039B4): Failed to Power on with Error 'The process cannot access the file because it is being used by another process .'.

What's wrong with it?

1
  • Do you have the VHD attached to another running VM? Mar 29 '14 at 19:36
6

It's also possible for Windows to lock a VHD file. I ran into this by double-clicking on a VHD, which causes recent version of Windows to open it up like a folder. However, it appears that the system then holds a lock on the file, which prevents Hyper-V from using it to start a VM. Rebooting fixed that problem.

3
  • 9
    Rebooting is overly drastic. Just open Disk Management and un-mount the VHD.
    – longneck
    Aug 5 '14 at 19:09
  • That's even better Aug 5 '14 at 19:18
  • @longneck Could you please post this as an answer so it can be marked as the solution?
    – Dennis
    Oct 13 at 14:52
1

While some of the simple answers provided above may work for some users, none of them solved my issue. My problem was that the Hyper-V .vhdx file for my virtual machine was locked but not appearing in either File Explorer as an ejectable disk nor in Administrative Tools Disk Management component. Note that my VM is a Debian Linux derivative running under WSL2 in Windows 10 with Hyper-V enabled.

So how did it become locked in the first place? I followed the instructions from an article on the web that said I can easily view files by simply double-clicking the .vhdx file. With the virtual machine shut down for the moment I did just that but got an error message (something about "can't read file"). Afterwards, trying to connect to my virtual machine with Hyper-V resulted in the error message "the process cannot access the file because it is being used by another process". So how to unlock it?

After scouring the web and trying various procedures I finally found one that worked by using the Powershell. Here's the short procedure:

  1. Search for Powershell and then Run as Administrator.

  2. At the command prompt type: get-physicaldisk

In my case the results were:

Number FriendlyName           SerialNumber    MediaType   CanPool OperationalStatus HealthStatus Usage            Size
------ ------------           ------------    ---------   ------- ----------------- ------------ -----            ----
1      SanDisk Ultra II 480GB 16xxxxxxxx96    SSD         False   OK                Healthy      Auto-Select 447.13 GB
0      WDC WD1001FALS-00E3A0  WD-WCATxxxxxxx9 Unspecified True    OK                Healthy      Auto-Select 931.51 GB
2      Msft Virtual Disk                      SSD         False   OK                Healthy      Auto-Select     32 GB

As you can see there is an entry called "Msft Virtual Disk" which represents the VM file mounted as a virtual disk.

  1. To unmount the virtual disk, from the command prompt type:
   Dismount-DiskImage -ImagePath "C:\Users\Public\Documents\Hyper-V\Virtual hard disks\Name-Of-Your-Virtual-Machine.vhdx"
  1. Re-enter the command: get-physicaldisk to verify that the virtual disk is unmounted.

After that the virtual disk was unmounted and I was able to successfully connect and load my virtual machine from Hyper-V once again.

I hope this information helps someone!

0

I had the same issues a few days ago:

Microsoft Emulated IDE Controller Error(Instance ID 83F863B-8DCA-9EDA-2CA8B33039B4): Failed to Power on with Error 'The process cannot access the file because it is being used by another process...

I tried to remove the USB Drivers and IDE - CD-ROMs. Re-initiate permissions again, but it didn't solve the issue.

I had to create a new VM and attach the hard disk. It solved the issue.

Hope that helps.

0

When you will click the virtual drive like computer\user\public\publicdocument\hyper-v\virtual machine\documents and settings the a new drive is opened in My computer. Right click the specified drive and "eject', then go to Hyper-V and start the Virtual Machine.

0

Very very simple. Simply go to vm setting. Then in the left pane just under the IDE controller 1 click DVD Drive and then select none. Job done.

0

Go the your Hyper-V Manager, locate the failing Machine settings, go to its virtual Hard drive, inspect the drive on the right pane and then reconnect the drive. Finish the wizard and your machine will start normal.

0

I found it. Eject new driver than created by click on .vhdx your vm.

1.Open your master/physical FILE MANAGER on windows server than hyper-v installed.

2.Select last driver

3.Right Click on last driver

4.select Eject

5.Now you can start vm in Hyper-v

1
  • "driver" or "drive"?
    – Dennis
    Oct 13 at 14:50
0

If you are handling VM:s with a solution as LabBuilder, you might actually have rebound the parent of a snapshot disk. I.e. using the same disk twice.

That might happen when you try to re-install a Hyper-V lab that has snaphots configured. Then all data disks will be bound twice.

In my case, Location 1 - 3 has been added once more as Location 4 - 5.

[![Hyper-V Settings with the same disks bound twice][1]][1]

To start be able to start the VM, simply remove the additional bound disk images at Location 3 - 5. [1]: https://i.stack.imgur.com/xhdZB.png

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.