4

I'm trying to connect to a Windows Server 2012 R2 using RDP.

It works fine using the ethernet cable, but it gets stuck on "estimating connection quality" if I try to connect using WIFI. The WIFI router gives me access to the exact same network the cable does.

  • The server is hosted on Amazon.
  • I can connect to other internal servers and also on Azure VMs via RDP at the same client machine.

Any thoughts?

7
  • Is the server connected via WiFi as well? – EEAA Mar 31 '14 at 21:29
  • Tks. The server is hosted on Amazon (I updated the question). – Andre Carlucci Mar 31 '14 at 21:37
  • 4
    Set the connection quality manually. Problem solved. – HopelessN00b Mar 31 '14 at 21:45
  • @HopelessN00b I tried to do that in past, but it didn't work. After your comment, I came back, set the connection quality and also unchecked all visual options (desktop compostion, visual styes, etc). That did the trick. Please, put your comment as an answer so I can mark it as correct and you get the points. Thanks. – Andre Carlucci Apr 2 '14 at 12:35
  • @HopelessN00b Ohhhhh I'm so sorry! I was so eager to solve the problem that I tried your solution in the wrong server (internal IP 192.168.14.12 instead of 192.168.14.13). The problem still persists even setting everything manually :( – Andre Carlucci Apr 2 '14 at 12:57
1

If having Windows detect your connection quality is giving you grief, I would recommend working around the problem by setting it manually. (The Experience tab of the built-in Windows RDP client, mstsc.exe).

enter image description here

Once you've selected any of the other options, you can manually adjust the settings (by checking or unchecking the check boxes) to be whatever you wish.

1
  • Please, see my comment above. I'm so sorry to make you answer here. Any way, maybe this method could solve other people's problem, but unfortunately it didn't work for me. – Andre Carlucci Apr 2 '14 at 13:00
0

I have the same, the Terminal Server 90 days Evaluations License was expired, you need to purchase proper TS CALs License

1
  • Could you describe how terminal server knows the network configuration on client and how does the licensing affect only WiFi without preventing all connections? – Esa Jokinen Apr 5 '15 at 14:47
0

I was having the same issue on a Windows 10 machine remoting to Server 2012. I had to restart the machine every time I logged in. I found that the mstsc.exe (RDP Session) got hung up in the task manager. When I killed the process in task manager and restarted a fresh RDP session it went through with no issues. JP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.