On running ADPrep passes all prerequisite, but fails in the last stage with the below error:

ADPrep execution failed --> System.ComponentModel.Win32Exception (0x80004005): A device attached to the system is not functioning.

ADPrep log says:

Adprep requires access to existing forest-wide information from the schema master in order to complete this operation.

I'm using the credentials of Enterprise Admin (schema admin too) couldn't find why it still throws access denied error.

  • 1
    Well, where is your schema master? Apr 1, 2014 at 4:32
  • Its Server 2008R2 which is GC in 2008R2 forest level.
    – Nandan
    Apr 1, 2014 at 4:44
  • Check domain integrity - can be you lost the schema master at some point in the past and never bothered to reassign it? Was there another DC once, time ago?
    – TomTom
    Apr 1, 2014 at 4:51
  • Yes there seems to be no problem there..For urgency after 2012R2 failed i have successfully installed another additional 2008R2 which is working fine that shows no problem in Schema or domain integrity. Problem is only with making 2012R2 an additional domain controller. Currently I have below DC's 1 2008R2 -GC,Schema Master the Default. 2.2008R2 -Additional DC (to be removed after 2012R2 come up) 3.2008 -RODC
    – Nandan
    Apr 1, 2014 at 5:09
  • Can you try to run ADPrep on the schema master manually? (pleaes back it up first!)
    – MichelZ
    Apr 1, 2014 at 6:42

3 Answers 3


I'd comment on the original question so I can gather more info before posting my answer, but I don't have enough reputation yet as I'm new; go figure right :)

Anyway, I've ran into this twice for two different clients, one that was running SBS 2003 and another running 2008 R2 like you are. Both times had a few different tweaks but ultimately the solution turned out to be this:

  1. Remove the Active Directory Domain Services role from the 2012R2 server if you have already installed it.

  2. Reboot.

  3. I know you already said you had Enterprise and Schema rights, but make sure you're using an account with Enterprise, Schema, and Domain admin creds.

  4. Reboot the 2008 R2 DCs; yes all of them.

  5. Go to the 2012 R2 server and add the Active Directory Domain Services role and reboot after it successfully adds.

  6. Once logged back into the 2012 R2 server open Server Manager and on your post installation tasks you should see something similar to this screenshot: enter image description here

picture source: http://blogs.interfacett.com/wp-content/uploads/2013/02/015-promote-domain-controller-server-2012-add-a-child-domain-ad-ds.png

click on the link "Promote this server to a domain controller" (ADPrep (both forest and domain) will run automatically without manually needing to have you run it from a command prompt)

  1. Reboot the server once the dcpromo finishes.

If you are still having trouble please look for the value in ADSI Edit for your server entitled "ClaimIsValueSpaceRestricted"; it will either be true or false. Let me know if it's true or false and if it's greyed out or not. We can troubleshoot further should we need to, but steps 1-7 should resolve your issue.

  • Brad, i have already done all your 6 steps. I get the exception in ADPrep and never completes.
    – Nandan
    Apr 21, 2014 at 10:01
  • I don't know if you can, but can you add a 2012 (non-R2) server and add it as a DC without any issue? Apr 21, 2014 at 17:08
  • Also, what about the ADSI Edit value I referenced, did you look at it? Apr 21, 2014 at 17:09
  • 1
    I didn't yet chenked a non R2 server yet as it was not my intention to build 2012(non R2), though its not a bad idea. It did failed in step 6 with the same old error "DPrep execution failed --> System.ComponentModel.Win32Exception (0x80004005)"
    – Nandan
    Apr 22, 2014 at 11:50
  • I coudnt find this attribute in ADSI edit! Sorry can u pls help where to look at?
    – Nandan
    Apr 22, 2014 at 11:51

Here is what I did to get it to work

  • Setup a Windows server 2008
  • Promoted it to a domain controller.
  • I still got the ADPrep execution failed --> System.ComponentModel.Win32Exception (0x80004005): A device attached to the system is not functioning.
  • Some discussion I saw suggested access to the schema master was the issue and recommended moving the schema master to the 2008 server.
  • This wouldn’t work from the Schema Master MMC so I used ntdsutil.
  • Went back to my 2012 server and attempted to promote it again. When given a choice out what DC to replicate from, I pointed to the 2008 server. I got a lot further that time, but still failed. Ran it again and pointed it to the old SBS 2003 server and it worked.
  • Due to licensing SBS 2003 servers must hold all 5 FSMO roles, which means it must be the "Schema Master". There is however a grace period to allow for migration. After that the SBS server shuts down every couple of hours or some other thing to make it useless in the environment. Jul 24, 2015 at 4:53

I had the exact same error and the solution from https://community.spiceworks.com/topic/304023-adding-server-2012-as-dc-to-server-2003-domain-getting-adprep-error?page=2 solved it for me:

Check the Remote Registry service on the 2003 domain controller is configured as follows:

Startup type: Automatic

Service Status: Started

Security context: NT Authority\LocalService (In Log On tab of remote registry service)

Then promote the 2012 server again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.