Here is what I want to do:

On a switch / router running cisco IOS ( Ideally it would work on a Lanbase image on a 3560G but it is possible to use 65xx routers also ) I receive two udp multicast streams on vlan 100:

  • vlan 100, @239.34.1.1:1234 and @239.34.1.2:1234

What I need to do is to forward:

  • @239.34.1.1:1234 on vlan 101
  • @239.34.1.2:1234 on vlan 102

For the time being I do not care about igmp snooping, which is disabled ( multicast traffic is treated as broadcast ), but an ideal solution would forward igmp queries from vlan 101/102 to vlan 100.

As suggested by @metacom I did the following:

I am running: ipbasek9 / 12.2(44)SE6

ip multicast-routing distributed
no ip igmp snooping
ip igmp ssm-map enable
no ip igmp ssm-map query dns
ip igmp ssm-map static 11 192.168.0.41
ip igmp ssm-map static 12 192.168.0.1
ip igmp ssm-map static 16 192.168.0.6
vlan 100
 name video feeds a and b
vlan 101
 name video a

interface vlan 100
 ip address 192.168.0.146 255.255.255.0
 # How am I supposed to explain that feeds 239.34.1.1 and 239.34.1.2 have a source on vlan 100?
 ip igmp static-group 239.34.1.2 source ssm-map
 ip igmp static-group 239.34.1.1 source ssm-map
 ip pim passive

interface vlan 101
 ip address 172.16.5.17 255.255.255.248
 ip igmp static-group 239.34.1.1 source ssm-map
 ip pim passive

ip pim ssm range 88

access-list 11 permit 239.34.1.1
access-list 12 permit 239.34.1.2

access-list 88 permit 239.34.1.1
access-list 88 permit 239.34.1.2

With this configuration, I have a server with a trunk connection to both vlans. On vlan 100 I can see ( via tcpdump for example ) the 239.34.1.1 and 239.34.1.2 streams. On vlan 101 I do not have any multicast streams.

When I run show ip mroute I see nothing. I do not know how to configure pim. In this image I have only pim passive , I do not know if it is a good or bad thing to activate it.

EDIT

I have activated ip pim passive on both SVI and here is the result for show ip igmp groups 239.34.1.1

Group Address    Interface                Uptime    Expires   Last
Reporter   Group Accounted
239.34.1.1       Vlan101                 00:07:19  stopped   0.0.0.0         
239.34.1.1       Vlan100                 00:07:31  stopped   192.168.0.36

Also if I run show ip mroute 239.34.1.1 I do not have an incoming interface for this group:

#show ip mroute 239.34.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.0.1, 239.34.1.1), 00:14:42/00:02:34, flags: sTI
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan101, Forward/Sparse-Dense, 00:14:29/00:00:44
    Vlan100, Forward/Sparse-Dense, 00:14:41/00:02:34

Configuring Static Traffic Forwarding with SSM Mapping : http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipmulti_igmp/configuration/xe-3s/imc-igmp-xe-3s-book/imc_ssm_map.html#GUID-DDD77D1A-D5C2-4402-A7C6-D1728B94A833

This sounds like exactly what you need.

The configuration would add an acl for vlan101 permitting 239.34.1.1 and one for vlan 102 allowing 239.34.1.2. Enable pim sparse-mode on all 3 vlans, ssm-map, multicast-routign and you should be good to go!

Edit: I just closed 44 tabs from trying to figure this out!

Edit 2: Change

ip igmp static-group 239.34.1.2 source 192.168.0.1
ip igmp static-group 239.34.1.1 source 192.168.0.41  

to

 ip igmp static-group 239.34.1.2 source ssm-map
 ip igmp static-group 239.34.1.1 source ssm-map

Edit 3 From here: http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipmulti/command/imc-cr-book/imc_i2.html#wp1533460393

ip mroute 192.168.0.0 255.255.255.0 192.168.0.146

And also you can probably remove

 ip igmp static-group 239.34.1.2 source ssm-map
 ip igmp static-group 239.34.1.1 source ssm-map

from vlan 100

  • I tried ssm but I can't get it work. Can you look my configuration and tell me what is wrong? – Olivier S Apr 9 '14 at 7:54
  • could you give me the output of: show ip igmp group 239.34.1.1 detail and also enable passive pim on both vlans – metacom Apr 10 '14 at 14:17
  • I have edited the question with the requested configuration changes / request – Olivier S Apr 10 '14 at 19:29
  • Check Edit 2.. the formatting in the answer section makes it easier! – metacom Apr 10 '14 at 20:11
  • I did the change, the question is edited. No change on the show ip mroute and show ip igmp groups results. And still no multicast traffic flooded on vlan 101 – Olivier S Apr 10 '14 at 20:33
up vote 0 down vote accepted

After much troubleshooting, I think that it is simply impossible to route multicast traffic with a lanbase image.

As stated in the doc If you need PIM for an SVI uplink port, you should upgrade to the IP services feature set.

On a old 3550 running 12.1(22)EA1a, the trivial following configuration is working fine:

ip multicast-routing

interface Vlan100
 ip address 192.168.0.146 255.255.255.0
 ip pim sparse-dense-mode
end

interface Vlan101
 ip address 172.16.5.17 255.255.255.248
 ip pim sparse-dense-mode
 ip igmp static-group 239.34.1.1 source 192.168.0.1
end

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.