Essentially I would like to set-up a proxy for YIM!. The reason for this is my office is within a shared office block with other companies, thus meaning the main office is blocking certain connections.

Instead of going to the MD and going through the paper-work, I thought I could create a SOCKS proxy. My problem is that, regardless of what i've done the connection is still not working.


I have my local machine running ssh -D 10001 myserv (Where myserv is configured as a host inside /etc/ssh/ssh_config only defining the hostname)

localhost: Ubuntu Desktop 13.04

myserv: Ubuntu Server 10.11

I've installed pidgin and configured it to use a SOCKS proxy. The configuration is set to:

Host: localhost

Port: 10001



I have provided no credentials which didn't work, I then provided them and still no luck.

  1. My first question is what is the difference between SOCKS, SOCKS4 and SOCKS5?
  2. In regards to my firewall, do I need to open any outgoing ports on my localhost, or myserv?

1 Answer 1


SOCKS4 and SOCKS5 are different versions of the protocol, with SOCKS5 supporting UDP and authentication. Use it if possible.

In your setup, myserv needs to be able to make arbitrary outgoing connections.

To debug, run your ssh command to myserv with -v. You should then see connection attempts in your SSH session:

$ debug1: Connection to port 10001 forwarding to socks port 0 requested.
debug1: channel 3: new [dynamic-tcpip]
debug1: channel 3: free: direct-tcpip: listening port 10001 for port 80, connect from port 50699 to port 10001, nchannels 4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .