0

I've been following the instructions from Mark Minasi's newsletter article to sysprep a Windows 7 image. However, during a test deployment I discovered that my time and date format changes were not preserved when creating a new user on the newly deployed system.

How do I make sure that time/date format is preserved during this process? Thanks!

P.S. Here is the sysprep answer file I am using:

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<CopyProfile>true</CopyProfile>
</component>
</settings>
<settings pass="generalize">
<component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipRearm>1</SkipRearm>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<Order>1</Order>
<CommandLine>cmd /c del c:\windows\panther\unattend.xml</CommandLine>
</SynchronousCommand>
</FirstLogonCommands>
</component>
</settings>
<cpi:offlineImage cpi:source="catalog:e:/install_windows 7 ultimate.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
1

You can set the timezone in the sysprep.xml file. Information about which passes this is valid for and which values are supported can be found here: http://technet.microsoft.com/en-us/library/cc749073(v=ws.10).aspx

If you're using WSIM for this, it is in the Microsoft-Windows-Shell-Setup node and the value you're setting there is Timezone as you would expect.

  • 1
    Oh whoops. I just re-read your question and this doesn't answer it! I'll try and update as soon as I have a minute. – MDMarra Apr 8 '14 at 15:23
1

Progess!

Following the suggestion here, I modified the date and time format settings at this place in the registry:

HKEY_USERS\.Default\Control Panel\International

I changed entries such as sShortDate and sShortTime to my desired values. After sysprep new users created on the system all seem to follow these customisations.

I'd still prefer if this could be achieved in a sysprep answer file, somehow that feels cleaner. But the registry changes described here is satisfactory for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.