How do I upgrade OpenSSL using Ubuntu's repository?

I see the USN at http://www.ubuntu.com/usn/usn-2165-1/

and the package here https://launchpad.net/ubuntu/+source/openssl/1.0.1-4ubuntu5.12

but I can't find instructions on how to use that to upgrade my OpenSSL version.

The standard update commands don't upgrade my version of ssl:

sudo apt-get update
sudo apt-get dist-upgrade

OpenSSL> version
OpenSSL 1.0.1 14 Mar 2012

How do I get the latest version from the repository?


dpkg --list openssl

||/ Name                      Version                   Description
ii  openssl                   1.0.1-4ubuntu5.12         Secure Socket Layer (SSL) binary and related cryptographic tools

aptitude show libssl1.0.0

Package: libssl1.0.0              
State: installed
Automatically installed: no
Multi-Arch: same
Version: 1.0.1-4ubuntu5.12
Priority: required
Section: libs
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Uncompressed Size: 2,991 k
Depends: libc6 (>= 2.14), zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0
PreDepends: multiarch-support
Breaks: openssh-client (< 1:5.9p1-4), openssh-client (< 1:5.9p1-4), openssh-server (< 1:5.9p1-4), openssh-server (< 1:5.9p1-4),
        libssl1.0.0 (!= 1.0.1-4ubuntu5.12)
Replaces: libssl1.0.0 (< 1.0.1-4ubuntu5.12)
Description: SSL shared libraries
 libssl and libcrypto shared libraries needed by programs like apache-ssl, telnet-ssl and openssh. 

 It is part of the OpenSSL implementation of SSL.
  • have you tried apt-get update && apt-get dist-upgrade? – Zoredache Apr 8 '14 at 16:22
  • So what is the version of the package that you have installed? – Michael Hampton Apr 8 '14 at 16:27
  • I did apt-get update && apt-get dist-upgrade (as I said in my post) on a few of my servers and they're still reporting version 1.0.1 14 Mar 2012. – ameagher Apr 8 '14 at 16:27
  • Please don't make me repeat myself. – Michael Hampton Apr 8 '14 at 16:29
  • I guess I don't understand your question. How do I determine the version of the package I have installed? – ameagher Apr 8 '14 at 16:31

Can you do aptitude show libssl1.0.0? You probably have the right patched version if you did apt-get dist-upgrade and rebooted, but it doesn't show up in openssh version, because ubuntu packages programs differently. Edit: typo

  • I edited the output of aptitude show libssl1.0.0 into my question. I guess I don't get it. Even though version outputs 1.0.1 14 Mar 2012 it's not correct? – ameagher Apr 8 '14 at 16:48
  • Ubuntu doesn't always provide you with the new upstream versions (that could sometimes break something unexpected), but releases patches that fix the problem, but still output the same version number. That's why you have to check the full version with aptitude (the last number is 5.12) so you can find out if the fix is present on your machine. Also in ubuntu openssl is split into multiple packages (openssl, libssl, ...). – Jure1873 Apr 8 '14 at 17:53

sudo apt-get update

sudo apt-get upgrade

Also don't forget to restart services using OpenSSL

  • This didn't work, as stated in my question. Even after rebooting the server I don't have the correct version installed. – ameagher Apr 8 '14 at 16:28
  • Worked for me :) – user3227965 Apr 8 '14 at 16:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.