0

Our application packs serialized XML datasets, and sends over FTP to the main server, running FileZilla 0.9.44, released yesterday. We've also tried it on 0.9.27.

Among about 70 clients, just one gets an error message while uploading a 5 MB binary file to the Filezilla FTP server, "An existing connection was forcibly closed by the remote host", from FileZilla server, and exactly after 2 minutes, every time. Each client uses it's own user credentials, all in same user group, and user settings are the same with others on Filezilla server.

I've checked router settings to see if there's a blocking setting. OS is Windows XP, many other clients run on too.

Edit: We've tried FileZilla client for sending the same file and same exception thrown. But Filezilla is able to resume after reconnect.

  • Maybe a Firewall in between closing the connection? Seems more like a client side problem than server side, if all other clients work – MichelZ Apr 9 '14 at 12:19
  • @MichelZ The only chance of firewall is the dsl gateway, and firewall is turned off. also no anti-virus or firewall software (incl. Windows) is running on PC. I do not think that ISP is blocking passive ftp. – Mehmet AVŞAR Apr 9 '14 at 14:10
  • I'd bet it's either the DSL router running out of NAT session space (oldest gets bumped), or it's got some really low timeouts on sessions. – NickW Apr 9 '14 at 14:14
  • @NickW Makes sense, but it's a common end-user dsl modem, no such settings (NAT session timeout) available. Probably it's a bug in router software. – Mehmet AVŞAR Apr 10 '14 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.