0

I have Windows Server 2012 and iSCSI storage. On the storage, I created a RAID1 array out of two 2TB disks and connected it over iSCSI to the server. But the server sees the connected device as follows:

DISKPART> list disk
 Disk 6   Online    1341 GB
 Disk 7   Online    1862 GB
DISKPART> list volume
 Volume 3    H    NTFS    Partition    1341 GB    Healthy
 Volume 4    E            Partition    3725 GB    Healthy

(Not all connected disks are online, do Volume 4 is on the Disk 7) The size of the disk is OK, but the size of partition is the physical size of the array. The partition cannot be formatted, if I try, it stays on 52% and doesn't continue.

enter image description here

I tried to disconnect and connect it multiple times, I tried to recreate the array a few times and nothing helps. It looks the same in Disk Management. If I connect the iSCSI disk in Linux, everything is fine.

The iSCSI target is Promise vessraid 1840i.

Any suggestions? Thank you very much for your advice.

  • Oooooohh, great, so much time in wein :( Do you see the star behind the Disk 7? Means it has GPT instead of MBR partition. It is being kept after soo many removals and recreations of the array in different sizes probably from the very first array which was used on those disks. So remove and recreate partition solved this issue. – Tomyk Apr 15 '14 at 20:45
0

The disk has GPT instead of MBR partition - it could be seen in DISKPART in the right column. The storage probably keeps the data from former array. So remove and recreate partition solved this issue.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.