1

I'm in the process of migrating from Exchange 2003 to Exchange 2010. The new server is setup, all mailboxes have been moved to it, autodiscover and OWA are working properly, no problems.

Now the last step before I can decomission the old server are the public folders. When I try to right clic on the public folders database then move replicas to move them to the new server (on which I created a new public folders database), I get the following error :

"The HTTP service used by Public Folders is not available, ..." ID no: c1030af3

Googled that for two days now, checked ADSI Edit, the correct server names are set, checked in IIS on Exadmin and Public virtual directories, they are put on the correct values, directory security seems ok, all windows services related to Microsoft Exchange are running, but no luck.

I've read that public folders are not mandatory any more on Exchange 2010 (we don't have any public folders except the default ones created by the system, and don't have any Outlook client prior to 2007 version). So I thought, let's delete them and go on, but Exchange 2003 don't seem to let me delete them.

How can I get rid of that so I can decomission the old server and turn it off ? It's annoying me as I cannot create email address strategies based on organizational units because legacy servers are detected ...

Thanks

  • Just checked IIS logs, and saw the url called presents the wrong domain name : /Exadmin/Admin/mydomain.local/Public Folders/ instead of /Exadmin/Admin/mydomain.info/Public Folders/. When I call these urls into a web browser, the first returns a 503 service unavailable, the second returns a nice OWA like UI presenting the public folders. So, how can I set the good domain name to resolve my issue ? – Sierramike Apr 10 '14 at 10:30
0

Okay, I finally found out the problem after the last investigation, you should not change the domain name in the default address strategy. If you did that like I did long ago, you must revert to the domain that was originally set when exchange was first installed.

If you already did install a newer Exchange, you have to do that on the new server because the old one will complain it has not the latest version of the organisation.

After reverting this setting, public folders did work again and I was able to start the move replicas command.

Hop this can help someone in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.