What options do I have to connect to a remote Windows server if RDP is broken (unresponsive), I don't have console access, and the server isn't physically close?

On Linux, if VNC wasn't working, I could usually rely on an SSH daemon. Windows never picked that up (why, I don't know) - is there any equivalent?

  • 2
    There are LOTS of ways...but it also depends on WHAT you are trying to do on the remote server. Some are easier than others based around that knowledge. – TheCleaner Apr 10 '14 at 19:24
  • 1
    ILO/DRAC I think is your best bet, seeing as how Powershell remoting is not enabled by default in 2008, and I bet you never enabled it, so it won't do you much good now until you can get in to the server to enable it. – Ryan Ries Apr 10 '14 at 20:02
  • Is the whole server unresponsive or just RDP. Anyway, nothing else would be of use if there was no UP routing path between you and server. – Matt Apr 10 '14 at 20:13

The first thing I do when RDP is not talking is this in Powershell:

PS> $service = get-service -computername MyServer -displayname "Remote Desktop Services"
PS> $service.stop
PS> $service.start

The majority of the time this revives RDP and I can get back in. If this doesn't do the trick then I have to rely on iLO or one of the other console options mentioned in other answers here.

| improve this answer | |

See this question here for your command line options. Basically, you've got WinRS/WinRM, PowerShell Remoting and PSexec and the other SysInternals Suite utilities. You can also install SSH, or even telnet on a Windows server, and connect to that, once it's installed.

Additionally, your tools in the Administrative Tools folder will let you connect to remote machines (or at least) try, so that's an option. (Mostly your MMC snap-ins, but even some of the natively included standalone exes, like regedit, have this functionality.)

You also should have some form of Out-of-Band management interface/virtual console on your server (such as HP's iLO or Dell's iDRAC), and if not...well, learn from this and get one on your next server.

Finally, there are any number of third party tools that will often allow you to access a server remotely, install themselves, and then set up a screen share based on VNC (or similar). Dameware and IntelliAdmin come to mind immediately, but they're just two of many.

| improve this answer | |
  • Ahh, the benefit of hindsight. Maybe he'll install some other options next time he runs into this kind of trouble. – Matt Apr 10 '14 at 20:12

PowerShell is what you're looking for. TechNet PowerShell Remoting

| improve this answer | |

Since it hasn't been mentioned:

There's always "smart hands". Never underestimate the simplicity of calling someone and saying "can you walk over to the server and tell me what you see? ...OK...do this for me."

Unless the server is orbiting the earth, that is likely an option.

| improve this answer | |
  • 5
    I'm more familiar with the fallback option, "Dumb Hands". It's more prevalent, if not always labeled and sold with the correct name. – mfinni Apr 10 '14 at 20:30
  • 4
    Unless your server is in the cloud...orbiting the earth. – Paul Draper Apr 11 '14 at 5:13

LoM is a commonly used technique to access nodes which is unaccesible in logical terms.

The name of the techniqu differs from manufacters, dell call their version 'iDRAC'. HP call theirs 'iLo'

In the earlier days there was specific PCI cards for this, called MEGARAC. There is also KVM over IP to help.

Best of luck!

| improve this answer | |

psexec, part of the Windows Sysinternals package.

We used to use this all the time to deploy software across a non-Active Directory network of Windows hosts.

| improve this answer | |
  • This one will work if you know the credentials to access the server... used it several times... the only "gotcha"---> you can't use GUI... only console... I mean... you can use console to launch a GUI program but you cant control it... – ZEE Apr 11 '14 at 13:44

Like said above iDRAC, iLO are best way to access remote systems if RDP fails to start. If the system is a virtual machine you could use virtual infrastructure to remotely manage and in most case view the console.

I'd invest in something such as a LANTRONIX 'Spider" also which could be hooked up to the VGA and USB ports of the remote system to allow for our of band management.

If you are still able to ping the system try to issue a restart to the box In windows 'shutdown -i' bring up an interactive command utility. See if that would allow you to remotely reboot the system.

Best of luck to you my friend and feel free to ping back for any additional help

| improve this answer | |

As long as the WinRM service is configured correctly you can enter-pssession –computername –scriptblock or invoke-command -computername –scriptblock using powershell. Or you can download Psexec from http://technet.microsoft.com/en-gb/sysinternals/bb896649.aspx and then user psexec \target –u credentials cmd

In-respect to RDP, is it even enabled? Check network registry of the server HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

There are values like fDenyTSConnections & TSUserEnabled that need to be configured correctly.

Also restart the TS services on the server.

I’m suggesting you use this if you have network access and can authenticate.

Do you also imploy ILO in your company?

| improve this answer | |

Used the same approach when RDP wasn't starting with the error "can’t connect because connection broker couldn’t validate the settings specified in your RDP file". Somehow AnyDesk was offline on the server as well at this time. And I had no access to the server physically. Got myself PsTools from http://technet.microsoft.com/en-gb/sysinternals/bb896649.aspx as advised by @Ben Lavender And followed the following steps;

  1. Opened cmd on my laptop connected through VPN to access the client's LAN and run the following commands in the path of the extracted PsTools. (At this point I had already figured out that the Windows Internal Database Service was the cause of this. You can read more about it. The Remote Connection Broker Service depends on it and so do other RD services, so for me WID was the culprit.)

  2. I run a query to find the status of the WID service psservice \[computername or IP] -u [username] -p [password] query "Windows Internal Database" WIDs state In my case the service was not running

  3. I the ran the command psservice \[computername or IP] -u [username] -p [password] start "Windows Internal Database" to start the service and got the result below. WID start state

  4. I queried the WID service again to confirm that it was now running and voila there it was. WID running state

When I tried RDP again, I was able to succeed this time round.

Hope this clarifies things better for you and solves your problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.