-2

I'm trying to get Tor running with a self compiled version of OpenSSL (compiled with enable-ec_nistp_64_gcc_128) I've configured OpenSSL with ./config enable-ec_nistp_64_gcc_128 --openssldir=/usr/local/ssl. I try to configure Tor with ./configure --with-openssl-dir=/usr/local/ssl but I always get

checking for openssl directory... configure: WARNING: Could not find a linkable openssl.  If you have it installed somewhere unusual, you can specify an explicit path using --with-openssl-dir
configure: WARNING: On Debian, you can install openssl using "apt-get install libssl"
configure: WARNING:    You will probably need libssl-dev too.
configure: error: Missing libraries; unable to proceed.

How must I configure Tor to use my custom OpenSSl version?

closed as off-topic by Sven, MadHatter, Rex, Katherine Villyard, Ward Apr 11 '14 at 20:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – Sven, MadHatter, Rex, Katherine Villyard, Ward
If this question can be reworded to fit the rules in the help center, please edit the question.

3

Solution: I compiled OpenSSL with

./config enable-ec_nistp_64_gcc_128 shared zlib-dynamic --prefix=/usr/local/openssl --openssldir=/usr/local/openssl

and then Tor with

./configure --with-openssl-dir=/usr/local/openssl --enable-static-openssl

Not the answer you're looking for? Browse other questions tagged or ask your own question.