0

I am running an AWS VM and tried:

sudo yum update

Result:

Error: Protected multilib versions: sendmail-8.14.4-8.12.amzn1.x86_64 != sendmail-8.14.4-7.9.amzn1.i386
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-2.6.34.7-56.40.amzn1.x86_64 has missing requires of mkinitrd
sendmail-8.14.4-8.11.amzn1.x86_64 is a duplicate with sendmail-8.14.4-7.9.amzn1.i386

I read else where to try this:

sudo yum --exclude=kernel* update

But same result.

This is a production server which I want to upgrade so I have to take special care. I was not the one preparing it. Looks like I use the amazon version of Red Hat 4.4.6-3.

Any suggestions how to fix this?

  • Try removing both sendmail packages with yum (or if that fails, rpm) then reinstalling it via yum. – sciurus Apr 11 '14 at 20:22
1

When you install both 32 bit (.i686) and 64 bit (x86_64) versions of the same library, they must be of the same version. If you examine the Error messages that you posted above, you'll see that the versions are not the same (the "!=" part means "does not equal").

Use following commands to fix the error,

Use package-cleanup to remove duplicates.

package-cleanup --dupes
package-cleanup --cleandupes

clear the yum cache,

yum clean all

then finally update the system with,

yum update

This post has more details, Fedora Forums & Red Hat Yum Reference

  • I tried that, but it still fails. The package cleanup command says "no duplicates to remove". Otherwise everything looks fine. After all the update fails with the same reason. Going to check the reference links now, but I am happy for all other suggestions you might have. – Christian Apr 11 '14 at 9:37
0

Use yum distro-sync instead of yum update to fix package version mismatches in this scenario. This allows for packages to be downgraded if necessary to match the versions in the repositories.

  • Thanks, but that command brought the same result. I also did a clean before. My message comes after: "--> Finished Dependency Resolution" – Christian Apr 11 '14 at 19:58
0

You can try the below this will ensure your downloading the latest release from the repository.

  1. Make sure that "releasever" in /etc/yum.conf is set to "latest"

  2. sudo yum clean all

  3. sudo yum update

  • It was already "latest". Redoing the steps didn't help :-( – Christian Apr 23 '14 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.