25

I am using the Citrix Receiver in Windows 8, and on Windows XP on another PC. I often log into work from home and am unable to span the session to dual monitors like one can easily do when using "mstsc" (Remote Desktop) by using "mstsc /span". Can this be achieved with either setting options on the server (Citrix server) or on the machines the client (Citrix Receiver) is installed on? I don't have access to the server, but if there is a way, I can put in an employee request for this.

http://receiver.citrix.com

4
  • Wouldn't your IT department be a better target for this question?
    – joeqwerty
    Apr 13, 2014 at 4:30
  • I asked them several months ago. They didn't know.
    – MacGyver
    Apr 13, 2014 at 4:41
  • So they said they didn't know and didn't take up the task of finding out? That's horrible. That's why IT people get a bad name.
    – joeqwerty
    Apr 13, 2014 at 4:44
  • You might want to contact your reseller or Citrix directly, since Citrix isn't cheap and for what you're paying they ought to give you more than MacDonald's free smiles. Apr 13, 2014 at 5:39

9 Answers 9

33

Once connected to remote desktop, drag Citrix window across both monitors. Press the maximize button, the client will maximize to both screens and be presented as a dual-monitor setup.

4
  • What version are you on?
    – MacGyver
    Sep 10, 2014 at 22:53
  • 1
    I can confirm that this solution works. Until I dragged the window to my second monitor, nothing helped. As soon as I dragged it there and maximized on my second display, it started to maximize on both from that time.
    – Ihor Bobak
    Dec 10, 2019 at 6:57
  • worked like a charm, pretty good.from a Windows Server 2016
    – Jack Wu
    Feb 23, 2020 at 9:52
  • +1 Confirmed this works if I resize the windowed Citrix window across all 3 monitors of various sizes then maximize.
    – JuliusPIV
    Mar 5, 2020 at 16:41
14

Put the Receiver into windowed mode and put it so half of the window is on each monitor, then maximize it and it should go fullscreen / dual screen.

4
  • It works like a charm
    – suraj_fale
    Dec 30, 2015 at 17:04
  • I think this presents as a single window. I am using a Laptop/TV with different sizes and the area not covered by my monitors (including window's start menu) isn't accessible.
    – Bill K
    Dec 8, 2016 at 19:06
  • worked very well. Thx Oct 24, 2019 at 13:43
  • I had to comment on this one. Worked PERFECTLY! Thank you!
    – B-Rad
    Mar 25, 2020 at 14:10
8

I figured this out. If you installed the Citrix Receiver, and have the browser plugin, you will need to disable that plugin so that a *.ica file does not launch automatically with the ICA Client when it finishes downloading.

Edit the file in a text editor and change the TWIMode=Off, to TWIMode=On. This will allow the window to span to both monitors. The monitors need to be the same size, and the resolution also needs to be the same on both monitors. Save the file. Then run the file (note: for the first time). The file becomes obsolete the second time you run it because the authentication token expires on the server.

UPDATE:

Google Chrome Menu > click "Settings" > click "show advanced settings" blue hyperlink > click "Content Settings" button > click "Disable individual plug-ins" blue hyperlink > then toggle "Enable" / "Disable" blue hyperlinks for the Citrix ICA Client plugin (name might be different depending on version)

7
  • Thanks for your post and good to know it works for you. But can you elaborate a bit on how you disabled the plugin and where you accessed the *.ica file? Thanks again. Apr 14, 2015 at 20:41
  • It's kind of deep in settings.. see my update
    – MacGyver
    Apr 14, 2015 at 20:50
  • By disabling that plugin, it doesn't automatically launch the *.ica file. If it doesn't launch, the authentication key won't expire until you launch it at least once. So once you disable it, edit the file, then save it, and then open the *.ica file manually. You can hack a lot of things with the application that launches in the Citrix Farm with this method. It's very useful for troubleshooting.
    – MacGyver
    Apr 14, 2015 at 20:54
  • Great.. I will give it a try. Thanks for the update. Apr 14, 2015 at 21:13
  • I am using IE 11 actually..and even though I disabled the Citrix ICA client plugin as you mentioned, it doesn't let me save the .ica file. It loads it way too quickly for me to do anything. If I knew where I could go in C:\Program Files (x86)\Citrix to edit it, it might help..looked but couldn't find a .ica file. Apr 15, 2015 at 3:37
4

On a MAC, it's easy as dragging the corner of the desktop window across monitors. For Windows, is much more cumbersome. On the Citrix Receiver icon at the top left corner of the Desktop window, click on resize session, select Full Screen for Desktop Size. To get out of Full Screen mode do a SHIFT+F2 If anybody know a better way, please post Thanks

2
  • I am running on Windows, but hopefully your post is useful to others. In our particular default *.ica configuration, the window size is locked.
    – MacGyver
    Sep 25, 2014 at 22:27
  • 2
    Now, in 2019, on a Mac, just go to the View menu in Citrix Viewer and select "Use all Displays in Full Screen." Sep 23, 2019 at 12:11
2

In my case, Critix Player shows me up with a remote desktop log in window exactly same as Windows' default remote desktop program.

(Disclaimer: I am not allowed to post the exact screen shot but the one below from internet is what I see )

As soon as the checkbox below gets checked, I do not have to do monkey with the dragging and resizing the window. Also, please make sure that the slider is set towards the right most corner such that the value below reads "full screen". If you do not see something similar to below, try to find an option which reads "show options" and clicking on it would expand your window, then click on "Display" tab.

enter image description here

2
  • This solution worked perfectly for me
    – Cyberflow
    Dec 8, 2017 at 3:12
  • so simple once you know how. thanks so much.
    – Laurence
    Jun 16, 2019 at 11:27
1

Good day, all. Here is a simple solution from the Citrix side. I created a cmd file with the command "mstsc /span" and shared it as a Citrix application. It worked when I tried it and I'm have other users test. GWHIZ

0

I found that as I'm logging in there is a box that has the name of my work computer that in the bottom left corner there is a show options. I click on it and it expands to where I can click on a box that say Use all monitors in a remote session.. It worked for me... Since you previously had 2 screens I assume that the Screen Resolutions already has the box changed to read Extend these Displays..

1
  • For other readers... what product/software, version, and edition is your server running on? +1 if you can provide that :-)
    – MacGyver
    Oct 2, 2015 at 21:36
0

When Citrix is up on one screen -restore it to a window on your desktop. Drag the Citrix window between the two monitors -and Maximise. When the window refreshes, it will be across both screens as desired.

1
  • There is no such option in my session. Dec 23, 2019 at 14:26
0

On the remote Desktop icon in citrix before entering credentials just click show options and click display tab. Tick the box to use all monitros for remote session. Con

Not the answer you're looking for? Browse other questions tagged or ask your own question.