7

I asked the same question on stack overflow but I only got 5 views, I think this is a better forum for this question.

I'm setting up CI for a C# project hosted on github in a private repo. Git is installed on master CentOS machine, MSBuild on slave windows.

I've created account on github, and added it to my private repo. When I'm setting up source control on Jenkins, I've entered URL (as https://github.com/.../repo.git) and entered credentials with the new account.

Jenkins reports:

Failed to connect to repository : Command "git config --local credential.helper store --file=/tmp/git2956041026506359040.credentials" returned status code 129:
stdout: 
stderr: error: unknown option `local'
usage: git config [options]

Config file location
    --global              use global config file
    --system              use system config file
    -f, --file <FILE>     use given config file

Action
    --get                 get value: name [value-regex]
    --get-all             get all values: key [value-regex]
    --get-regexp          get values for regexp: name-regex [value-regex]
    --replace-all         replace all matching variables: name value [value_regex]
    --add                 adds a new variable: name value
    --unset               removes a variable: name [value-regex]
    --unset-all           removes all matches: name [value-regex]
    --rename-section      rename section: old-name new-name
    --remove-section      remove a section: name
    -l, --list            list all
    -e, --edit            opens an editor
    --get-color <slot>    find the color configured: [default]
    --get-colorbool <slot>
                          find the color setting: [stdout-is-tty]

Type
    --bool                value is "true" or "false"
    --int                 value is decimal number
    --bool-or-int         value is --bool or --int
    --path                value is a path (file or directory name)

Other
    -z, --null            terminate values with NUL byte

If I log into master and try the same command on root console I get the same error, --local is not an option for git config.

  • You should not cross-post on stackexchange sites, you should ask a moderator to move your question to another site. – MichelZ Apr 16 '14 at 10:35
5

CentOS 6 (I'm just going to assume version 6 here) is shipping git version 1.7.1.
The --local switch was introduced with version 1.7.4.
Therefore it is not available in the version you are using.

  • Update of Git to 1.7.11 solved the problem. Thank you. – user3043457 Apr 16 '14 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.