I have a network share on Windows server in my local network. I can access this share using smbclient on my Ubuntu 13.10 (with installed cifs-utils package) desktop like this:

smbclient \\\\192.168.5.2\\source -W DOMAIN -U My.User.Name%my.password

but if try to mount this share using mount like this:

sudo mount -t cifs //192.168.5.2/source /mnt/192.168.5.2/ -o username=My.User.Name,domain=DOMAIN,password=my.password

I got error:

mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I also tried to add corresponding line in /etc/fstab file, but it return same error on 'sudo mount -a' I think it may have something to do with server setup - I disable ntlmv2 in smb.conf adding line:

client ntlmv2 auth = no

without that line smbclient method doesn't work either. But I still can't figure it for mount

  • Is there possibly another session to the server already established with different credentials? Only very recent versions permit multiple security tokens across the same channel. – Pekka Apr 16 '14 at 12:29
  • No, there is no another session to this server – ShockwaveNN Apr 16 '14 at 12:40
  • @ShockwaveNN have you ever figured out what the problem was? – dmeu Jul 6 '15 at 9:37

Could you check the Security tab of the Windows Share. Does My.User.Name exists in the Group or user names box? Could you check whether the user has enough rights? Could you open windows explorer, navigate to \\192.168.5.2 and check whether the directory appears?

If this works as you already have indicated in the question. Could you indicate whether you have installed sudo apt-get install cifs-utils?

I mount windows folders like this:

  • //<ip>/files /tmp/hello cifs credentials=/home/<user>/.smbcredentials,iocharset=utf8,sec=ntlm 0 0 at /etc/fstab
  • credentials file:
    • username=user
    • password=pass
  • sudo mount -a should mount the folder
  • Windows Server settings are correct - I use same credentials in 'smbclient' command and it works fine. Cifs-utils are installed and your method with .smbredentials file return same error - mount error(13): Permission denied – ShockwaveNN Apr 16 '14 at 12:41
  • Which Windows version are you using? – 030 Apr 16 '14 at 14:24
  • I have the exact same problem, and also via the fstab-option, i get a Permission denied error – dmeu Jul 6 '15 at 9:38

I'm not sure whether you're using Group Policy to control settings on your Windows machine, however I had this exact same problem and fixed it in our environment. I had set 'Server SPN target name validation' to 'Accept if provided by client'. This was enough to consistently give an error code of 13 NT_STATUS_ACCESS_DENIED. Turning this setting off, and refreshing the policy on the Windows machine allowed mount.cifs to work.

If you're not using group policy, check the local security policy in case this setting is more restrictive.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.