0

I've got a domain model network. I set up DFS (Distributed file system) on a server running Windows Server 2008 R2.

Every thing is OK. The problem is here that users using Windows 7 can't access to their shared folder that I created on their computer using DFS. Of course they can access other dfs shared folders.

  • 1
    What? You used DFS with Shares on Windows 7 computers? I didn't even know that was possible. – joeqwerty Apr 17 '14 at 5:02
  • @joeqwerty: Sure, why not? You can use ANY share with DFS, it can be linux shares as well... (at least for non replicating DFS). Have a look here for details: technet.microsoft.com/en-us/library/cc753448(v=ws.10).aspx, paragraph "Requirements for servers hosting folder targets" – MichelZ Apr 17 '14 at 8:59
2

You need to Enable DFS Loopback Targets:

Registry on the client computers:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Mup\Parameters

Create a DWORD (32-bit) value named EnableDfsLoopbackTargets, and then set the value to 1.

After changing the value, restart the computer

From: http://technet.microsoft.com/en-us/library/cc753448(v=ws.10).aspx

Although computers running Windows Vista® or Windows® 7 can host folder targets, they are generally unsuitable for use as file servers. In addition to their limit of 10 concurrent incoming SMB connections, computers running Windows Vista or Windows 7 by default cannot navigate a DFS namespace to a folder target hosted on the local computer. For example, if a user on a computer running Windows Vista (\client1) attempts to connect to a DFS folder whose folder target is a shared folder located on the same computer (\client1), the connection attempt will fail. This is considered a loopback connection. This behavior is designed to help prevent a rogue namespace server from redirecting a client computer to an administrative share on the client computer (for example \127.0.0.1\C$), and then reading or writing files in the shared folder. To allow a client computer access to folder targets located on the local computer (the default behavior on servers), open Registry Editor, navigate to the following location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Mup\Parameters, create a DWORD (32-bit) value named EnableDfsLoopbackTargets, and then set the value to 1. After changing the value, restart the computer. To disable DFS loopback targets (the default behavior on client computers), set the value to 0. After changing the value, restart the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.