1

I have an email server, running on CentOS 6.5, 32bit system, with Postfix and Dovecot running along all their dependencies. Let's assume my domain is www.anw.com

I have created A record in this order for my domain

    www.anw.com         37.143.374.15    # points to my web server
    anw.com             37.143.374.15    # points to my web server
    mail.anw.com        227.80.74.199    # points to my mail server

I have also created an MX server

   mail.anw.com    227.80.74.199

Now, using postfix I have created two accounts, namely joe@anw.com and jane@anw.com using squirrelmail I can send and receive between those accounts without any problem. I can also send emails to any email account like Yahoo and Google, but I can't receive emails sent from Google or Yahoo.

  • Post the output of netstat -lpn and your postfix configuration file. – Spack Apr 18 '14 at 14:49
  • @Spack pastebin.com/mT9RmXjK BTW: This is how I set up my email server – samayo Apr 18 '14 at 14:52
  • I miss the important part. Try netstat -ltpn instead. And also the content of /etc/postfix/main.cf. If not too big, just put it in your question. – Spack Apr 18 '14 at 14:56
  • @Spack No problem. Here is netstat ltpn and main.cf – samayo Apr 18 '14 at 14:59
1

In your /etc/postfix/main.cf look at the following settings and the associated comments:

myhostname (your mail server's host name) mydomain = dailytech24.com (you domain name) myorigin = $mydomain inet_interfaces = all (if you only have IPv4 then this needs to change) mydestination mynetworks

  • You can check my settings in the comment, because I have done all what you have written before. I did exactly mentioned in this tutorial – samayo Apr 18 '14 at 15:00
  • @ANW post the output of postconf ¦grep -i my please – GeneBean Apr 18 '14 at 15:07
  • I tried your approach, it gives me an error saying postconf: warning: ?: unknown parameter postconf: warning: grep: unknown parameter postconf: warning: -i: unknown parameter postconf: warning: my: unknown parameter – samayo Apr 19 '14 at 12:21
  • There is a pipe between postconf & grep – GeneBean Apr 19 '14 at 12:43
  • You should've given me | instead of ¦ :) Here is the pastbin pastebin.com/jGrLWMLG – samayo Apr 19 '14 at 13:00
1

Your Postfix is listening only on the Loopback interface (127.0.0.1). Edit the /etc/postfx/main.cf file and update the inet_interfaces parameters with your public IP address.

inet_interfaces = MY.IP.AD.DR,127.0.0.1

You will then have to restart the Postfix service.

# service postfix restart
  • Sorry my WiFi maxed out yesterday, but I tried it just now, and no result. Just so you know, there was inet_interface in main.cf. It was like this: inet_interfaces = all I am here if you want to ask me any more questions, and thanks so far @Spack – samayo Apr 19 '14 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.