-1

I have built 2 x windows 2003 r2 servers, during the teaming of two nics, the nics would not team correctly due to an issue with the switch I was connected to, only one nic would work, the second was disabled.

Windows went into a high security mode and wouldn't allow me to run or install any exe files.

After the network issue was resolved and i successfully teamed the network cards, but windows still wont allow the installation of .exe's etc.

Troubleshooting as below

  1. I've removed the server from the domain and re-added.

  2. Tried removing the block notification as suggested below but this ineffective as it effects every .exe file.

  3. I've removed Data Execution Protection as suggested below but the problem is the same.

This problem is the same on both servers that suffered this teaming issue, there is a block on all files and an error message with a permissions message appears is attached.

I think the only option now is to fully rebuild the servers.

Here is the error message:

Windows cannot access the specified device, path,or file. You may not have the appropriate permissions to access the item.

enter image description here

5
  • 3
    What is the exact text of the error message?
    – Zoredache
    Commented Apr 18, 2014 at 16:35
  • 2
    There's absolutely nothing in Windows that could block the execution of files due to network adapter issues. The two things are completely coincidental.
    – Massimo
    Commented Apr 18, 2014 at 16:48
  • 2
    This question appears to be off-topic because it contains none of the relevant information required to accurately assess the issue, such as an error message or what troubleshooting was performed. This question may be a better fit on psychicIT.stackexchange.com Commented Apr 18, 2014 at 17:26
  • I've updated the original post.
    – JJJJNR
    Commented Apr 19, 2014 at 14:15
  • The servers were rebuilt and the error has not reappeared.
    – JJJJNR
    Commented Apr 24, 2014 at 11:25

2 Answers 2

4

Right click the .exe, choose Properties. There, you should have a button Unblock. Click it, try to execute it again.

This usually happens for files on network drives, or copied from the internet.

6
  • Upvoting your answer. Heh. It's been awhile since I was primarily '03. :D Commented Apr 18, 2014 at 16:53
  • 1
    Still got some 2k3's around in the testlab, happens occasionally ;)
    – MichelZ
    Commented Apr 18, 2014 at 17:00
  • This is from anything from my local network or even when i move files over to the local machine.
    – JJJJNR
    Commented Apr 19, 2014 at 14:16
  • 1
    Yes, anything from "outside" which was not trusted before
    – MichelZ
    Commented Apr 19, 2014 at 14:19
  • So how do i unblock this for every exe going forward.
    – JJJJNR
    Commented Apr 21, 2014 at 12:14
1

This is probably Data Execution Protection and not related to your network cards. Check your DEP settings in Properties -> Advanced -> Performance Settings -> Data Execution Protection and see if that helps.

enter image description here

3
  • Thanks, this was enabled its now disabled but the problem remains.
    – JJJJNR
    Commented Apr 19, 2014 at 14:17
  • Even when you follow @MichelZ's answer? Commented Apr 19, 2014 at 14:41
  • Yes, every exe on the machine is blocked even from the network shares or when it copied to the local drive.
    – JJJJNR
    Commented Apr 19, 2014 at 14:57

Not the answer you're looking for? Browse other questions tagged .