I've searched high and low for help with this. What I've found is that most have given up.

I have found that I can mount the samba share from a few different windows hosts with different users. However, there are other windows hosts that are unable to mount the same share using the same set of credentials.

On the windows hosts I get "The specified network password is not correct". I am not seeing anything written to the smbd.log.

Any help or guidance will be appreciated. I've tried various tweaks of the config and I took a trace but didn't get any helpful information.

EDIT: Samba version 3.0.33-3.39.el5_8

All windows clients are windows 7. Based on information found regarding the Windows version and compatibility with SMB version I inserted the following inserted the following into my smb.conf and restarted but with the same results.

client max protocol = SMB2

Do I need to consider installing an older version of Samba?

Unfortunately I don't have the access to AD today to find out the version but will ask tomorrow.

My samba configuration in smb.conf is as follows:

server string = Samba Server Version %v
netbios name = SERVER1
workgroup = EMEANB
security = ADS
username = /etc/samba/smbusers
log level = 1
syslog = 0
winbind separator = +
realm = EMEA.XXX.INT
password server = AB1.EMEA.XXX.INT AB2.EMEA.XXX.INT 
idmap uid = 100000-200000 
idmap gid = 100000-200000 
template homedir = /home/%U 
template shell = /bin/bash 
winbind use default domain = yes
winbind offline logon = false
winbind enum users = yes
winbind enum groups = yes
smb ports = 139
obey pam restrictions = no
load printers = no
cups options = raw
    comment = Home Directories
    browseable = no
    writable = yes

    comment = All Printers
    path = /var/spool/samba
    browseable = no
    guest ok = no
    writable = no
    printable = no

    comment = shared
    path = /tmp/share
    public = yes

Not enough info for a proper answer (need to know Samba level, Active Directory version and windows client version).

However, check the version of SMB authentication supported by your flavour of SAMBA and your Windows clients. You may need to upgrade your Samba distro or down-level the supported levels of SMB authentication on your clients.

Other thoughts would be around Kerberos, but issues here would typically be wider reaching.

  • I've updated with some extra info. I tried making a change in smb.conf to specify the max client smb version. – rahimbah Apr 22 '14 at 13:15

I found the solution and also found that it had been answered on serverfault previously. I have provided the link below.

link to solution

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.