4

host: intel i7-4* cpu, running linux kubuntu 14.04

guest: attempting to create.

ubuntu-vm-builder kvm saucy

eventually,

Get:1 http://archive.ubuntu.com/ubuntu/ saucy-updates/main linux-image-3.11.0-19-generic amd64 3.11.0-19.33 [14.5 MB]
Get:2 http://archive.ubuntu.com/ubuntu/ saucy-updates/main linux-image-virtual amd64 3.11.0.19.20 [2302 B]
Fetched 14.5 MB in 6s (2335 kB/s)
Selecting previously unselected package linux-image-3.11.0-19-generic.
(Reading database ... 10289 files and directories currently installed.)
Unpacking linux-image-3.11.0-19-generic (from .../linux-image-3.11.0-19-generic_3.11.0-19.33_amd64.deb) ...
Selecting previously unselected package linux-image-virtual.
Unpacking linux-image-virtual (from .../linux-image-virtual_3.11.0.19.20_amd64.deb) ...
, stderr: grep: /proc/cpuinfo: No such file or directory
This kernel does not support a non-PAE CPU.
dpkg: error processing /var/cache/apt/archives/linux-image-3.11.0-19-generic_3.11.0-19.33_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.11.0-19-generic /boot/vmlinuz-3.11.0-19-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.11.0-19-generic /boot/vmlinuz-3.11.0-19-generic
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-3.11.0-19-generic_3.11.0-19.33_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

isn't this supposed to work?? an i7 does have PAE. a grep on pae in /proc/cpuinfo confirms it. and

and

 kvm-ok
  INFO: /dev/kvm exists
  KVM acceleration can be used

does anyone know what is going on here?

/iaw

1

I don't know about your PAE CPU being treated like a non-PAGE CPU. However, we had the same error message, This kernel does not support a non-PAE CPU, and this worked for us:


Kernel does not support a non-PAE CPU install KVM guest on Ubuntu 13.10 – Fix

...

Basically, you just need to ensure that the linux-image-generic package (i.e. a kernel which supports non-PAE CPU’s) is installed by setting the addpkg flag like so:

--addpkg=linux-image-generic

Source: randomhacks.co.uk


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.