0

I am trying to set up MX record of my domain to point to the google server. According to the google documents I should enter the following values for MX record of my domain

https://support.google.com/a/answer/174125

But the settings of the domain panel doesn't accept the values in no way, I tried to contact the hosting company to get help, but they don't provide any help and just had given me the panel for settings, I even don't know which panel it is

it look like as the following picture which may be familiar for you http://radaut.com/layout.PNG

Anyway, my main problem is that I can't enter the settings for the MX record.

the error and the interface for entering the MX record is as the following picture

http://radaut.com/mx.PNG

the error for the google address is

Content must match "^([a-z0-9\-]+\.)+([a-z\@]{2,}|@)$"

My question is where and what should I enter to set up the MX to point to the google server.

1
  • 1
    Try lowercasing the name. – Jenny D Apr 21 '14 at 7:34
2

In your second screenshot above where you have tried to enter the MX Record of ASPMX.L.GOOGLE.COM. Looks like it's google who has caught you out with this one.

On Google's webpage the URL for the MX Record has a fullstop (.) at the end of it therefore the regex from the hosting company does not expect this and is throwing it out as an invalid host!

I would suggest aspmx.l.google.com - lowercase and without the fullstop at the end :)

Hope this helps!

1
  • Thank you, according to the Jenny D, I made it lowercase first, but then again encountered the problem then I removed the trailing point and it solved the problem, in fact both changes are necessary, because I had removed the trailing point before and had no success – Ahmad Apr 21 '14 at 8:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.