1

I am trying to configure a Postfix SMTP server on my personal machine (ubuntu server) using sasldb2. So far what I have set up works well with the test command:

testsaslauthd

(however it may be worth noticing that I have to do a chmod+x on /var/spool/postfix/var/run/saslauthd even though it belongs to the sasl group for it not to end up in a permission error. Note that I'm working in chroot)

However, when I telnet my server to try and authenticate against it, I get a very generic

5.7.8 Error: authentication failed: authentication failure

and /var/log/mail.log does not have more info (one line, approximately the same). My understanding is that it is a simple postfix misconfiguration and I have tried many different options without satisfactory results. My /etc/postfix/sasl/smtpd.conf is now :

pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true

(though I also tried auxprop with sasldb auxprop plugin). /etc/postfix/main.cf contains the relevant lines :

smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_path = smtpd
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtpd_use_tls = no

(I deactivated tls for now) Would you please point me in the right direction to get more information on and fix this authentication failure ?

  • I have exactly the same problem. Have you found a solution yet? – Matthias Aug 18 '14 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.