2

I'm trying to setup a ftp server for one of my websites hosted with IIS 8 on Windows Server 2012.

So I set up my website, everything worked fine and the website is reachable.
Then I rightclicked the website entry -> Add FTP publishing -> no assigned ip address, port 21, chose my self signed certificate -> next -> Authentification: Standard, Allowed access for user Administrator, Read/Write permissions checked -> Finished.

Now I tried to connect to the ftp server using Filezilla.
Everything is fine but I only have read-only access.

I searched google for this problem but nothing helped so far.
I checked folder permissions of the users Administrator/IIS_IUSRS but both should have the rights for read/write access.
I'm not very experienced with Windows server 2012 so I dont really know where to look for.

Anything I missed to configure?

  • Did you connect to the FTP server using the Administrator account? – user62491 Apr 22 '14 at 17:40
  • yes of course. other usernames dont work. – TorbenJ Apr 22 '14 at 19:20
  • Have you ever found a solution to your problem? – saxx May 5 '14 at 14:03
1

If I remember correctly the IIS_IUSRS account only represents anonymous IIS users, but when you publish via FTP you have to log in, therefore giving read/write permissions to IIS_IUSRS has no effect in your case.

Now this is where things tend to become a bit weird. Even though you log in as Administrator (or any administrative level user you might have) that still may not be enough, because depending on the impersonation type and level, your IIS may be accessing the web site root folder as a different user.

The most common scenarios are IIS accessing that folder as "IUSR_[computer]" or as "Network Service". Please check your directory for permissions on those accounts. Granting the proper permissions to those account should (likely) solve your problem.

0

You need to add the rights to the folder security option (shortcut from iis : edit permission on the right) I don't know why set user in FTP autorizations rules isn't enought...but any way that s how it works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.