I have a HP P800 array controller connected to a HP MSA60 with 12x 1TB SATA drives installed. I provisioned a single array with 1 spare in ACU. I have followed this KB and created 4x 1.9TB logical drives and a 1.5 TB logical drive.

I created a new VMFS-5 datastore from the first logical drive of size 1.9TB (named: vmh03-das02)

My issue is that when i try to extend the datastore to the other logical drives, as the KB suggests, there are no devices listed.

Does anyone have any idea why this would be?

screen shots can be seen here

  • The KB article you listed only applies to ESXi5/5.1. Have you tried it with 5.5? I've used the P410 with an MSA 2040 using a single vDisk greater than 2TB just fine with ESXi5.5. – Rex Apr 22 '14 at 18:36
  • I tried to create a ~10TB logical drive at first and it shows as 512b in vmware device list. If you create any logical drive 2TB or larger it shows as 512b, hence the 1.9TB logical drive sizes. – Aossey Apr 22 '14 at 18:43
  • @Rex - the P410 is a newer family than the P800, I've had problems with the P800 in the past - to be honest I've no idea what the problem is but I know that the P410/P812 and newer do support >2TB LUNs - that doesn't help you Aossey sorry, presumably the whole server is running at the latest BIOS/Firmware? – Chopper3 Apr 22 '14 at 18:47
  • Ill answer later. – ewwhite Apr 22 '14 at 19:07
  • Thanks for the comment @Chopper3, the server (DL580 G5) and the P800 are both fully updated. The P800 is at 7.24 firmware. – Aossey Apr 22 '14 at 22:15

Using extents in VMware isn't so great. The knowledgebase article you linked to is correct in that this is a driver limitation...

Your HP Smart Array P800 controller supports logical drives sizes larger than 2TB. The "limit" is 8 Zettabytes :)

You should update the controller firmware if you haven't already.

However, VMware uses two drivers for HP RAID controllers; the CCISS and HPSA. The HPSA supports the larger volumes, but not your controller (without hacking). The P400/P800 are basically stuck with the older CCISS driver.

So yes, you need to use extents here. I'm curious if you've rebooted and rescanned the storage devices since having this problem. You should be able to do this hot and without a reboot, but the rescan of LUNs may be necessary. Use the "Rescan All..." option.

enter image description here

If this doesn't work, your best bet is to obtain a Smart Array P810 controller, since it uses the newer driver and will see the full logical drive size.

  • Thanks so much for the response. I have rebooted and "rescanned all" but no love. Still don't have any extent devices in the wizard when i try to increase the datastore size. I would love to buy a new controller but unfortunately this is a home lab and I don't really have "budget" for it. Trying to make the best of what I have available. – Aossey Apr 22 '14 at 22:40

I was able to determine the solution to the problem based on the conversation in this thread. Originally I was trying to extend the datastore via my vCenter server, which it seems does not work. Based on the forum thread I tried to connect to the host directly, rather than the vCenter server, and I was able to successfully extend the datastore.

NOTE: I am unclear on if this should have worked via vCenter or not. Both the windows and web versions of the vSphere client present options to extend the datastore but I am not able to see any extent devices in either when connected to vCenter.

  • That's so mental, never heard of anything like that but I'm glad you persevered and got where you needed to be. – Chopper3 Apr 23 '14 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.