0

Okay, here's the deal:

I used FUSE to mount a webdav endpoint as a filesystem. At some point it broke. Now, for the life of me, I cannot unmount it.

Any time I try and interact with it in any way, things just freeze. Listing (ls) the directory which contains the mount point freezes my shell up unrecoverably.

I have tried umount -f (force), umount -l (lazy), umount -lf (lazy force) and fuser -km (as I've seen recommended elsewhere) all as root... No luck. Any time I run any of these commands they simply hang until I kill (^C) them.

There shouldn't be any processes keeping a handle open on this mount. I've tried checking with lsof. That, too, hangs.

I don't care if I have to compile a freaking kernel module to patch this thing out of memory... I need a way to get this gone.

I've spent the last hour searching Google and Stackoverflow. Everything is just a repeat of the same old party line: umount -f and umount -l. Does anyone know a way to really, truly force a filesystem to unmount?

(Debian 6.0.9, kernel 2.6.32-5)

  • 2
    Reboot should do it. – user9517 Apr 23 '14 at 4:09
  • 3
    In my experience, Linux won't unmount some filesystems and a reboot is the only practical way to clear the error. This used to happen with NFS a bunch. – Stefan Lasiewski Apr 23 '14 at 4:11
2

Here's another command you can try, though if the things are hanging that badly, this might not help either.

fusermount -u /path/to/mountpoint

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.