0

I'm having a weird problem:

My os is MacOsX 10.8.5.

What I try to do is to go to phpMyAdmin website and download the latest version. The problem is that the phpMyAdmin website won't load with Firefox, Chrome, Opera, Safari. By that I mean that I tried all those browsers, trying to open the phpMyAdmin home page url: http://www.phpmyadmin.net/home_page/index.php and it would display the url in the browser, saying that it's waiting for data from phpmyadmin.net, but it will never end, and the screen is blank meanwhile. I only have this behaviour with php my admin. All other websites load just fine.

My first thought was: "Ha, php my admin website is down". So I waited one day and started again: same results. Then I thought: "A big website like php my admin can hardly be down more than 24 hours". So I tried Tor browser, and it happens that Tor doesn't have any problem at all: I could open the url, and download php my admin without any problem.

Do you know what the problem could be ?

I tried to ping phpmyadmin and it times out. However, I can connect to phpmyadmin with telnet (I have to make about 3 tries to make a successful connection):

telnet phpmyadmin.net 80

Here is the result of traceroute:

~ > traceroute phpmyadmin.net
traceroute to phpmyadmin.net (216.34.181.97), 64 hops max, 52 byte packets
 1  neufbox (192.168.1.1)  1.987 ms  0.812 ms  1.347 ms
 2  22.85.118.80.rev.sfr.net (80.118.85.22)  34.543 ms  58.513 ms  31.762 ms
 3  129.133.64.86.rev.sfr.net (86.64.133.129)  31.440 ms  40.668 ms  32.450 ms
 4  138.133.64.86.rev.sfr.net (86.64.133.138)  31.962 ms  31.081 ms  32.290 ms
 5  46.134.64.86.rev.sfr.net (86.64.134.46)  33.575 ms  33.774 ms  32.531 ms
 6  146.133.64.86.rev.sfr.net (86.64.133.146)  30.776 ms  29.849 ms  31.237 ms
 7  109.69.26.109.rev.sfr.net (109.26.69.109)  32.367 ms  39.959 ms  38.813 ms
 8  222.224.65.86.rev.sfr.net (86.65.224.222)  36.595 ms  59.371 ms  48.434 ms
 9  te0-4-0-7.mag21.par01.atlas.cogentco.com (149.6.160.197)  46.350 ms  37.786 ms *
10  be2040.mpd21.par01.atlas.cogentco.com (154.54.78.37)  35.291 ms
    be2038.ccr21.par01.atlas.cogentco.com (154.54.74.253)  55.418 ms
    be2040.mpd21.par01.atlas.cogentco.com (154.54.78.37)  37.133 ms
11  be2274.mpd22.lon13.atlas.cogentco.com (130.117.50.97)  42.603 ms
    be2272.ccr22.lon13.atlas.cogentco.com (130.117.49.121)  45.106 ms
    be2273.mpd21.lon13.atlas.cogentco.com (130.117.50.93)  50.270 ms
12  be2315.ccr22.lon01.atlas.cogentco.com (154.54.73.110)  43.596 ms
    be2314.ccr21.lon01.atlas.cogentco.com (154.54.72.254)  44.053 ms
    be2317.ccr22.lon01.atlas.cogentco.com (154.54.73.178)  44.042 ms
13  be2329.ccr21.lon02.atlas.cogentco.com (130.117.49.90)  45.464 ms
    be2328.ccr21.lon02.atlas.cogentco.com (130.117.49.86)  43.905 ms
    be2329.ccr21.lon02.atlas.cogentco.com (130.117.49.90)  48.909 ms
14  savvis.lon02.atlas.cogentco.com (130.117.14.58)  44.558 ms  43.364 ms  61.481 ms
15  cr2-te-0-1-0-1.uk1.savvis.net (206.28.100.29)  47.944 ms  67.810 ms  46.757 ms
16  cr1-te-0-6-0-0.chd.savvis.net (204.70.198.118)  139.522 ms  138.708 ms *
17  hr1-te-12-0-1.elkgrovech3.savvis.net (204.70.198.73)  183.807 ms  206.154 ms *
18  * * *
19  * 64.27.160.194 (64.27.160.194)  159.363 ms *
20  * * *
21  * * *

As for web filters, there is no parental control filter applied.

I tried curl:

I was never able to get a result using:

curl http://www.phpmyadmin.net

However, I did have a response, trying 3 times, asking for headers only:

curl -i http://www.phpmyadmin.net

I tried to access the website using telnet, there is a response but no body!!:

~ > telnet phpmyadmin.net 80
Trying 216.34.181.97...
Connected to phpmyadmin.net.
Escape character is '^]'.
GET / HTTP/1.1
Host: phpmyadmin.net

HTTP/1.1 302 Found
Server: Apache/2.2.15 (CentOS)
Vary: Host
Location: http://www.phpmyadmin.net/home_page/index.php
Cache-Control: max-age=172800
Expires: Fri, 25 Apr 2014 06:10:22 GMT
Access-Control-Allow-Origin: *
Content-Type: text/html; charset=utf-8
Content-Length: 0
Date: Wed, 23 Apr 2014 06:10:22 GMT
X-Varnish: 423165287
Age: 0
Via: 1.1 varnish
Connection: keep-alive

Connection closed by foreign host.
~ >
  • Firewall? Web filter? ISP with a wacky null route? – Shane Madden Apr 23 '14 at 5:22
  • Try ping and traceroute. – Shane Madden Apr 23 '14 at 5:27
  • @ShaneMadden I'm sorry but I'm a complete beginner with security in general, could you be more specific about Firewall and web filters ? I tried a ping to phpmyadmin.net and it times out. Then I made a traceroute, and put the result in my updated post. Thank you for your help – ling Apr 23 '14 at 5:45
  • So you can connect with telnet? Try curl, or just sending a basic HTTP request in the telnet session? (GET / HTTP/1.1, enter, Host: phpmyadmin.net, enter, enter) – Shane Madden Apr 23 '14 at 5:54
  • @ShaneMadden Please see my updated response: curl works only with headers only, and telnet works but content length is 0. – ling Apr 23 '14 at 6:15
0

So finally, as suggested in comments, I tried to lower the MTU settings.

Using the technique described in this post, https://superuser.com/questions/413285/os-x-failure-in-path-maximum-transmission-unit-pmtu-black-hole-router-detectio

I was only able to lower MTU to 1280, so I did that, and then I could access phpmyadmin.net via a browser.

However, I have restablish MTU to 1500 and it stills work, so I don't know what that was, but now it's working anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.