1

I have a working setup with apache 2.2 server acting as a remote proxy.

I'm using proxytunnel with two chained proxies: proxytunnel -q -X -p localproxy:8080 -r remoteproxy:443 -d destination:22 I had to apply a patch for SSL to work though: https://issues.apache.org/bugzilla/show_bug.cgi?id=29744

I'm now trying to do the same using the apache 2.4 server (SSL issue is resolved in 2.4 apparently). The connection establishes immediately but after cca 20 seconds apache (remoteproxy) resets the connection to the local proxy, thus killing my SSH session. Keepalives didn't help.

I tried raising the log level LogLevel debug in the general apache config, but i'm not seeing any useful info. Is there a way to debug the mod_proxy itself in a more detailed manner?

  • Found out about trace1-8 debug levels but that ALSO doesn't show anything. Using LogLevel warn proxy:trace6 proxy_connect:trace6. In packet traces I'm just seeing sudden FIN/ACK from remoteproxy->destination and RST/ACK from remoteproxy->localproxy. No mention of any proxy activity inside /var/log/apache2. Only a single CONNECT line – vobelic Apr 23 '14 at 17:04
1

There's new feature to 2.4 called reqtimeout_module. You have to comment all the statements in /etc/apache2/mods-available/reqtimeout.conf and restart the server.

You can also check http://httpd.apache.org/docs/current/mod/mod_reqtimeout.html for more detailed info.

  • That was it! I disabled the mod altogether in the end and the setup from above works (with SSL between 1st and 2nd proxy). – vobelic Oct 4 '14 at 20:58
  • This is great answer! Why the hell was it voted down? – ExtraT Oct 25 '18 at 3:23
1

As mention before, disabling the mod_reqtimeout does the trick. I did it by adding RequestReadTimeout header=0 body=0 to the vhost configuration.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.