1

I recenlty set up two different switches in two different locations and had similar problems with both of them when it comes to connecting a network printer.

Switches:

Switch 1: Netgear GS724T 24 Port Gigabit Smart Switch

Configured with 5 different VLANs. One port is the trunk, all others are untagged. Storm control & Loopback detection enabled.

Switch 2: D-Link DGS-1210 24 Port Gigabit Smart Switch

Mostly unconfigured (no VLANs). Storm control & Loopback detection enabled.

There are several printers on each location and in both sites there is ONE printer dosn't even activate the LED of the new switch when connected but works like charm when connected to an old switch.

In one location the non-working printer is a big Xerox copy/printer and in the second location it's an old HP network printer.

In both locations I've tried:

  • Firmware updates of the switches
  • Enabling/Disabling VLANs
  • Different Ports
  • Different Cables (Cat5e,Cat6)
  • Resetting the printers and switches

Has anyone ever experienced something similar?

  • 1
    What about hard setting the port speed? Set it to 10-full or 100-full and see if you can set it on the printer side as well. Then check for connectivity again. – TheCleaner Apr 23 '14 at 19:02
  • Had a similar issue with some Extended Systems Print Servers (the old school kind with the Centronics port on them). I had to not use newer hardware as a work around while we found replacements for the units. I ended up using some Netgear EN104s in the middle between the GB switch and the printer. Messy, but it worked. – MikeAWood Apr 23 '14 at 21:03
1

Try configuring the duplex settings on the switch (connected to the printer) and the printer web interface manually and see what happens. Sounds like Auto Neg is failing for some reason.

  • Thought so.. Happy to help! :) – Rhys Evans May 1 '14 at 0:28
0

Double check your configs on the switches. Make sure the ports are enabled. Try plugging in another device in the same port on switch to confirm its not the port.

  • The ports are definitly enabled. When I connect my Laptop to one of them, I get an IP in the printer range. Also in the switch webinterface it says 0 TCP packages with errors on this port. The printer doesn't come online on any port of the new switch. In both locations and both (different) switches – Christian Apr 23 '14 at 18:40
  • Silly question but have you verified you're using a straight through cable and not a crossover? Most laptop NICs support auto-switching, whereas printers may not be nearly so robust. – Matthew Apr 23 '14 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.