0

I have a web server which hosts SVN. Its been working for ages without any issues but now all of a sudden doesn't want to commit any changes.

When I try and commit my project to SVN I get the following error message from the ankvsh client for Visual Studio, but i get the same error when using TortoiseSVN

Subversion reported an error:

Unexpected HTTP status 400 'Bad Request' on '/repos/Windows/ServerAdministrator/!svn/txr/0-a/ServerAdministrator/trunk/Middleware/ApacheAccessLog.cs' Additional Errors: PUT of '/repos/Windows/ServerAdministrator/!svn/txr/0-a/ServerAdministrator/trunk/Middleware/ApacheAccessLog.cs': 400 Bad Request

I've done a google and everyhing is saying that it is something related to a proxy. I am not using a proxy but forums were suggesting that if it is proxy related which is blocking the dav, to access the repository via HTTPS so the proxy server would just pass the connection through as it wouldn't see that it is a DAV request.

I've therefore generated a SelfSigned certificate and installed into apache but I still get the error above when trying to commit the project.

Thanks for any help you can provide.

UPDATe Below is a snippet of a lantrace hopefully it might help

Lantrace

0

Its not exactly a fix but I have found another workaround as all other work arounds on Google didn't fix my problem.

The problem seems to be something to do with OpenSuSE 12.3 and 13.1, but the issue is no longer a problem running Subversion on CentOS 6.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.