0

I've set up an RDS 2012 R2 host farm, but have problems.

When I try to log on from an outside client, then I get this error...

"An authentication error has occurred (Code: 0x607)"

I've tried google it, but without any result.

Any idea how to fix this?

0

This seems to have something to do with Certificates.

  • Make sure your RDS certificate is trusted on the remote host
  • Make sure you use the correct name to connect to the machine

If you have a self-signed certificate, this is what I found:

This is what I did to get RD session hosts bugged with 0x607 to work:

  • removed RD session host from collection,
  • deleted certificates from computer personal store on RD session host (this was plausible in my scenario),
  • removed RD session host role,
  • redeployed RD session host role from central RD administration.

This created a fresh self signed SSL certificate for internal RD session host FQDN and assigned it to RDP-tcp. Interestingly, that certificate doesn't even appear in RD session host personal certificate store...

See this TechNet thread for more information.

Another possibility (mentioned in the same thread) is to lower your security settings (not advised for a production environment though):

Edit the session collection properties and in "security" change "Encryption level" to low. and save session collection. And try to access that session collection from win 8 or win7 sp1, voila, it solves issue except one warning.

  • Thank you for helping me out here. I've tried both suggestions you came with, but it still fails with the 0x607 error code. :( I'm going nuts here. Btw. I did have a new selfsigned certificate in the local store. – MojoDK Apr 27 '14 at 8:40
0

I had the same nightmare with 0x607 and the above solution resolved the issue for me. I think the cause of the problem related to my having switched session hosts to different session collections and somehow the certs don't update properly. Removing the session host from the collection and then remove the cert from the computer personal & remote desktop stores, restart and the certs are recreated and problem resolved.

I practically rebuilt the entire RDS farm over 4 days until I came across this, so frustrating!

  • 1
    Could you specify what actions are needed where? What certificates, where they are located? What needed to be restarted? – Mike Fiedler Jun 14 '14 at 16:45
0

On your RD Session Host servers only (not your broker), please delete the following registry value:

HKLM\ SYSTEM\ CurrentControlSet\ Control\ Terminal Server\ WinStations\ RDP-Tcp

SSLCertificateSHA1Hash REG_DWORD

NOTE: Again, do not delete the above value from your broker. Only your RDSH servers.

After making the above changes, please test to make sure the issue has been resolved.

https://social.technet.microsoft.com/Forums/en-US/e0f8f58f-58c9-49fc-9d48-f6bfde830f17/rdweb-authentication-error-0x607?forum=winserverTS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.