I install an application, that it needed smtp information for sending mail, I provide smtp user, password and host for that application, but when it tried to send mail this error had occurred in the application:

"SMTPRecipientsRefused: {'ash.mavi@gmail.com': (550, '5.1.0 <bounce-14-res.users-5@aaslaam.com>: Sender address rejected: User unknown in virtual mailbox table')} ".

what should I do?

mail server log:

Apr 29 13:41:41 ns3 postfix/smtpd[30281]: connect from unknown[xx.xx.xx.xx]
Apr 29 13:41:41 ns3 postfix/smtpd[30281]: NOQUEUE: reject: RCPT from unknown[xx.xx.xx.xx]: 550 5.1.0 <bounce-15-res.users-5@aaslaam.com>: Sender address rejected: User unknown in virtual mailbox table; from=<bounce-15-res.users-5@aaslaam.com> to=<ash.mavi@gmail.com> proto=ESMTP helo=<ns1.webmart.com>

If you need to know more information, let me know.

  • Check your postfix logs, but thereis two spaces between "User" and "unknown", so there is no user provided to the MTA, and it reject your mail – Dom Apr 29 '14 at 10:58
  • I placed server log corresponding to this error. – Arash Mousavi Apr 29 '14 at 11:46
  • Are you using SRS? Also, since the email is from your domain (possibly) but to an external domain (gmail) it's normal that you wouldn't allow relaying from ns1.webmart.com – NickW Apr 29 '14 at 11:53
  • I don't know SRS, I simply install and configure postfix with installing iredmail. How can I found whether I using SRS or not? – Arash Mousavi Apr 29 '14 at 11:56
  • Don't worry about it. First, who is it sending that mail, second, is it in your network, third what are you trying to accomplish exactly? – NickW Apr 29 '14 at 11:59

Postfix rejected unknown senders. Comment out one line in /etc/postfix/main.cf:

#smtpd_reject_unlisted_sender= yes

and your problem will be solved.

  • 1
    This is a serious security risk. If your machine somehow gets hacked, your machine can be turned into a SPAMbot... – Homunculus Reticulli Nov 29 '16 at 19:20

If using a file instead of a table, run sudo postmap /etc/postfix/virtual_mailbox_maps after ensuring the target address in in there.

  • Can you explain how this will solve the OP's problem, given that there's no indication that Postfix is configured to look in /etc/postfix/virtual_mailbox_maps? – womble Mar 31 '20 at 21:25

Please check if the address where are you sending to is written correctly and there are no spelling errors,(space,dot, .etc).

Not the answer you're looking for? Browse other questions tagged or ask your own question.