2

This question already has an answer here:

How do I get my non-Windows (Linux, Mac) computers to properly register their IP address into my DNS server?

Server Name: AD1 OS: Windows Server 2008 R2 Roles: DNS, AD, DHCP

DNS SETTINGS
Dynamic Updates: Secure Only

DHCP SETTINGS
Checked - Enable DNS dynamic updates according to the settings below. Always dynamically update DNS records.

Checked - Discard A and PTR records when lease is deleted

Disabled - Name Protection

I've tried setting a DNS dynamic update registration credential user and then added that user to DNSUpdateProxy.

However, when I connect a Mac/Linux computer to the network, it'll get an IP from the DHCP server, but it will not add it's IP into the DNS. I cannot add these computers to the Windows domain.

I've searched around but can't seem to find a definitive solution. Any ideas?

EDIT
I changed from secure only to unsecure and secure to see if it would resolve the problem. It does not.

EDIT
Okay so I look at my DHCP logs here is what I see:

10,04/30/14,12:15:52,Assign,10.10.3.58,m-pro.domain.local,28GFE112B263, 11,04/30/14,12:16:19,Renew,10.10.3.58,m-pro.domain.local,28GFE112B263, 11,04/30/14,12:16:36,Renew,10.10.3.58,m-pro.domain.local,28GFE112B263, 11,04/30/14,12:16:53,Renew,10.10.3.58,m-pro.domain.local,28GFE112B263,

The first number indicates the Event ID.

10 A new IP address was leased to a client.
11 A lease was renewed by a client.
30 DNS update request to the named DNS server
31 DNS update failed
32 DNS update successful

On Windows clients you'll see something like this:

30,04/30/14,10:14:38,DNS Update Request,50.3.10.10,court.domain.local,,
11,04/30/14,10:14:38,Renew,10.10.3.50,court.domain.local,8CA9830B1060,
32,04/30/14,10:14:38,DNS Update Successful,10.10.3.50,court.domain.local,,
30,04/30/14,10:14:43,DNS Update Request,50.3.10.10,court.domain.local,,

So it looks like the DHCP doesn't even initiate and update request to the DNS server.

marked as duplicate by TheCleaner, mdpc, Rob Moir, MichelZ, Ryan Ries May 1 '14 at 12:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Each linux vendor may/may-not support this. I have seen success in this for SuSe and RHEL and it is a setting in the hosts' network configuration if I recall. Not sure about others. I'd check the OS vendor website to get this information. – mdpc Apr 30 '14 at 18:08
  • Well, making dymamic updates secure only is going to cause you problems, but see if this helps out any. – HopelessN00b Apr 30 '14 at 18:09
  • Added some more information. – Michael Apr 30 '14 at 19:28
  • Yes the link you just sent me I already tried by creating a user to specifically update records. – Michael Apr 30 '14 at 19:29
4

DHCP | Expand Server | Right-Click IPv4 | Properties

DNS Tab | Check "Dynamically update DNS records for DHCP clients that do not request updates (for example, clients running Windows NT 4.0)

That was the key to making this work.

I went ahead and set back Dynamic updates to Secure only in the DNS settings and my non-Windows clients are still able to update the DNS records. I also removed the created user "DNS dynamic update registration credential user" and it's still working.

Here is what my log looks like:

30,04/30/14,15:17:20,DNS Update Request,58.3.10.10,m-pro.domain.local,, 11,04/30/14,15:17:20,Renew,10.10.3.58,m-pro.domain.local,28GFE112B263, 32,04/30/14,15:17:20,DNS Update Successful,10.10.3.58,m-pro.domain.local,,

  • 1
    Hey @michael , if I'm reading this right, once you set the "Dynamically update DNS records for DHCP clients that do not request updates" option, all the DHCP clients just show up in DNS? right? – PsychoData Nov 20 '14 at 15:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.