1

I've got a very strange problem with Windows Server 2008R2 and 2012

I have two (unconnected) locations where I have similar problems:

I had a working Windows AD domain in both locations with a WDS server running on the DHCP Server. After enabling VLANs I wasn't able to install any machines via PXE boot.

One Location has only Windows Server 2008 R2 servers and the other Windows Server 2012 (not R2)

The servers have been restarted a few times since I added the VLANs and I've tried reconfiguring DHCP and WDS in both locations.

The WDS Server starts without problems and using netstat -a I can see that they are listening on all interfaces but I always get one of two error messages:

Error scenario 1: When I let the DHCP server also be the WDS it says something about DHCP Proxy timeout

Error scenario 2: When I put the WDS on a different server in the same subnet and change DHCP options 66 and 67 accordingly the client boots and seems to get redirected but then says that the WDS didn't answer him (No response from Windows Deployment Services Server)

I feel I need to re-initialize the server because of the new virtual nics - but wouldn't know how.

In a third location I use Server 2008 R2 as well with 8 VLANs and have no problems whatsoever.

Network facts:

  • The switches were not yet reconfigured so the VLANs are just on the Server for now
  • PXE installs were working in both locations without problems before adding the VLANs
  • I've tried all the solutions I could find like deleting the Mgmt folder, reconfiguring DHCP using command line and gui but nothing changed
  • Not even the Virtual Machine (Hyper-V) can install anymore
  • I've disabled every internal firewall in both locations
  • The logs of the WDS don't show any errors. They see that someone requests something from the TFTP and it always tells me it was successful
  • Everything else still wors as before (network printing, network shares, net logons, AD authentification, RADIUS authentification)
  • Both locations have a Windows Server as router having NAT enabled.. could that be a problem?
  • [UPDATE] I've created the VLANs on both servers with the Broadcom Advanced Control Suite 4

Am I missing something?

  • Are the workstations your're trying to PXE Boot on the same VLAN as the WDS servers? Also, as far as the WDS not giving an answer, what option have you selected for the known/unknown computers? By this I mean, have you allowed all computers regardless of their affiliation and domain properties the ability to communicate with WDS? Because if you haven't then that will cause issues when you try to boot and get the WDS server to talk correctly to the clients. Let me know the answers and we can troubleshoot further, thanks. – Brad Bouchard Apr 30 '14 at 22:15
  • Yes the DHCP/WDS Server has a virtual network card in every vlan and can be pinged and portscanned without errors. I also have disabled the authorization process for unknown clients so that souldn't be a problem. In my opinion it's a pretty standard scenario with a DHCP in every VLAN and WDS enabled. – Christian May 1 '14 at 8:01
0

Your problem is likely to do with the fact that PXE boot communication is broadcast and cant cross vlans without the configuration of ip-helper like address configuration.i would reference offical setup guides from microsoft on wds setup and read about the function of ip helpers.

OK, so your just currently messing with hyper v virtual networking to configure and test wds..which is strange as you would normally extend this out to your switching infastructure aswell. This is a bit problematic if you don't completly understand the comunication that takes place in a traditional scenario.

In a traditional scenario you may have; A WDS/PXE/TFTP server on a server Vlan A DHCP Server on a server Vlan

A Switch in the middle with interfaces on the different vlans and configured for ip helper address. A Client Workstation on the Client Workstation Vlan

Explains the communication process: http://technet.microsoft.com/en-us/magazine/2008.07.desktopfiles.aspx

Scenario 1 Error. WDS and DHCP cant be on the same server without additonal configuration as they use a port required for DHCP. IF you want to do this you need to set optoin 60 in dhcp

Senario 2 Error. THis will work if the client and server are on the same vlan, but not if they are on different vlans without configuring ip helpers like features on your hyper-v switches. Read this: http://windowsitpro.com/networking/configuring-dhcp-and-wds

  • Is there any chance that my (virtual) network cards are configured poorly not to allow broadcast? But since normal DHCP requests are processed and work in every VLAN that might not be the problem, right? If it helps: I used Broadcom Advaned Control Suite 4 in both locations to configure the VLANs – Christian May 1 '14 at 8:03
0

In your virtual Switching Enviroment; You may want to read this: http://www.virtualizationadmin.com/articles-tutorials/microsoft-hyper-v-articles/networking/virtual-networking-hyper-v-part1.html

"Both locations have a Windows Server as router having NAT enabled.. could that be a problem?"

OK ,no this is not a problem but Why is windows server acting as your router -this can be done in software,but its really not recommended- get a real hardware level router and switching infrastructure

0

I figured it out!

It was not the software at all, it was a broken Switch that slowed everything down. I replaces the switch and now it's working again.

Thanks for all of your input!

[edit] In the second location it was not the switch.

If you install a Windows server and install additional network interfaces AFTER you installed WDS (for example add VLAN adapters), it can't seem to use them (even after a few restarts). My solution there was removing WDS and DHCP (if on the same server, else just WDS) and reinstall them. After that it worked there too

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.