0

I've got a server that was running 4.2e. I heard about the 4.2f update, so I installed that (alongside, per the upgrade/validation instructions), but it fails to start at all. catalina configtest returns:

C:\Alfresco42f\tomcat\bin>catalina configtest Using CATALINA_BASE:
"C:\Alfresco42f\tomcat" Using CATALINA_HOME: "C:\Alfresco42f\tomcat" Using CATALINA_TMPDIR: "C:\Alfresco42f\tomcat\temp" Using JRE_HOME:
"C:\ALFRES~1\java" Using CLASSPATH:
"C:\Alfresco42f\tomcat\bin\bootstrap.jar;C:\Alfresco42f\t omcat\bin\tomcat-juli.jar" Error: Could not find or load main class ++JvmOptions=-XX:-DisableExplicitGC

I tried installing a standalone JDK as I saw on another post on the official Alfresco forums, but it didn't change anything. Tried to post this question to the Alfresco forums too, but it disappeared for awhile, then reappeared in the French language section where it's not getting any attention...

Ideas on why Alfresco can't find the Java that's built in?

  • 1
    Which version of the jdk did you install? The error you posted shows you're still using the Alfresco embeded jdk. – alxgomz May 3 '14 at 9:16
  • I tried both JDK 7U55 and JDK 8U5. Neither one had any impact. I've disabled the 4.2f services and rolled back to 4.2e, it works fine. Looks like the 4.2f distribution is broken, but if that was true I'd expect a lot more people than just me to be posting about it! – Brian Knoblauch May 5 '14 at 14:40
  • 5.0a is out now and that will run fine. Seems to be a problem specific to the 4.2f installer. – Brian Knoblauch Jul 11 '14 at 18:25
0

I'm told, by an Alfresco developer, that 4.2f only contains a single bug fix and that I should be fine jumping to 5.0a directly. So, that's what I'm going to do. I don't know what's up with 4.2f as other people are running it, but it won't work on Windows or Linux (even on completely fresh machines) for me.

If you can get 4.2f running, good for you. :-) If you can't, it sounds like it's safe to just avoid that whole trainwreck (IMHO) of a release. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.