I am trying to activate MS Server 2012 R2 Standard and I'm having issues.

I have installed the software from the ISO file I downloaded from the volume licensing site. I have learned that this file installs a KMS client version of the software by default. I have both KMS and MAK keys for this software but since I'm only installing 2 instances of the software, MAK makes the most sense to me. I don't have a KMS host running on my network so I need to use MAK client. However, I cannot get my MAK keys to work when I run a powershell command such as slmgr.vbs -ipk xxxxx-xxxxx-xxxxx-xxxxx-xxxxx. I always get the same result which is an error message 0xc004e016 - on a computer running ms windows non-core edition, run slui.exe to display the error text.

Basically, its telling me that it doesn't like the license code. So, is there a separate ISO file for MAK client installations or is there a way to convert this KMS client to a MAK client. There is some documentation on this on google but they did not work. Just received the same error message. Can anyone offer some assistance for this issue? Calls to MS support have so far provided no help.

  • Basically, its telling me that it doesn't like the license code Why don't you post the actual message?
    – MichelZ
    May 4 '14 at 7:32
  • Just for reference the actual message in this situation is: "This key didn't work. Please check it and try again."
    – James
    Apr 16 '18 at 17:00

The reason you can't activate it is because you are not connected to the internet. I learn it the hard way. 2012 R2's error is very generic. When you put the license key, it try active the license right way. Because you dont have internet, it cant verify it.

Here is for anyone who try activate over phone on machine that has no internect connection.

Here is the trick I finally figured out.

You can't activate windows by phone because you have not put in the correct product key number. Here are the steps and I was able to activate over the phone. I have not see any one post these steps yet. I spent 4 days with Microsoft trying to get some helps. With other user's input and I was able to put together the complete steps.

1.To Change Product Key Number in a Command Prompt Open an elevated command prompt. In the elevated command prompt, type in the command below and press enter.

NOTE: Substitute XXXXX-XXXXX-XXXXX-XXXXX-XXXXX in this command below with your actual product key number with dashes instead. slmgr.vbs /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

2.type slui.exe 4 to access the phone activation screen and follow the steps to activate over the phone.


Ok, I went back to MS Volume Licensing and downloaded the ISO file again for MS Server 2012r2 and I noticed that it was different that the one that I had previously installed. I reinstalled this OS on the server and my MAK key worked this time. So all is good again. Thank you for your input.


  • 1
    As others have said, the installation media is always the same, and it's not tied to any specific licensing mode; you can use either KMS or MAK, regardless of where you downloaded the ISO from; you can also convert your system to a KMS client anytime, by entering the default key for a KMS client. The ISO you downloaded could have changed for a number of reasons; the most likely one is, the VL portal periodically refreshes the available OS images to include the most recent product updates.
    – Massimo
    Mar 4 '15 at 19:44

I created an account just to answer this question. I just ran into this issue, and when I figured out the fix, I realized that I had run into this before.


That's it. For some reason Server 2012 R2 doesn't seem to sync up with an outside source at all, so until you set it manually, you're going to be off and activation and checking for updates won't work. For my install today the system thought it was November 2014 - 11 months ago!

  • if it's not DNS, than just your host machine's time setting.
    – KuN
    Feb 14 '19 at 16:56

The ISO is the same - it will accept the MAK key, or let you use KMS.

Make sure you aren't accidentally using the KMS key - that needs to be installed on a KMS server and won't work directly. Also make sure you installed the correct version of Server 2012R2 - some ISOs give you the option to install Standard or Datacenter, but the license key from one will not work on the other.

Also double check that you typed (or preferably copy/pasted) the key correctly - didn't mix up an 8 for a B, etc.

If that still fails, the easiest thing to do would be to install the GUI and activate it through the GUI, since you'll be able to see the full error messages easily. One of the nice things about Server 2012 is you can add and remove the GUI at any time.

If it still fails, you'll have to call Microsoft support for them to verify the license key is correct or issue you a new one. Contacting wherever you bought the volume license may be easier than calling Microsoft directly - they may know who best to call to handle licensing issues.

  • Thanks for the reply, I have the GUI installed already and I'm not able to activate it from there either. I made certain that we installed the standard version and also I'm using the MAK key. I've entered it in many times and I'm certain that I'm keying it in correctly... I've also copied and pasted it, but no joy. MS has verified that my MAK key is correct but that's as far as they got. I'm sure that it has something to do with the ISO install being a KMS client but I don't know what.
    – Deca
    May 3 '14 at 18:44
  • 1
    Once you enter a MAK key, the ISO is no longer a "KMS" client. Are you absolutely sure your key is for 2012 R2, and not "simple" 2012? These keys differ!
    – MichelZ
    May 4 '14 at 7:32

This can happen if you have no internet through the client firewall.

Even though the server looked like it had internet, because it could reach the DNS servers. Internet traffic was being blocked by the firewall the client had in place. Once the policy allowed the IP out, activation completed successfully.


Not the answer you're looking for? Browse other questions tagged or ask your own question.