2

I'm having some trouble getting Unbound to forward queries correctly.

My current unbound.conf looks something like this:

  forward-zone:
      name: "google.com"
      forward-addr: 8.8.8.8

  forward-zone:
      name: "."
      forward-addr: 127.0.0.1@1066  # An Unbound server with a single catchall 

  remote-control:
      control-enable: no

The 'google.com' zone returns correctly but the catch all zone doesn't. (Even though the query appears to be received and returned correctly on the 2nd unbound server)

7

I have the same problem, after searching I found the solution at the mailing list unbound-users: [Unbound-users] forwarders problem. Simply set:

do-not-query-localhost: no
  • 2
    It's worth noting that the above config option needs to be set in the server: section of the conf file. – Eborbob Feb 11 '16 at 12:16
0

I am a little confused, are you trying to query another server or the localhost on port 1066? If the latter you need to use the IP address that you have set under the interface portion of the config.

server:
     interface: <real ethX IP>

forward-zone:
  name: "."
  forward-addr: <real ethX IP>@1066

Unbound won't let you query localhost/127.0.0.1 by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.