0

So I am trying to setup a new data source in a Weblogic Server (12c), but I'm getting the same error over and over:

java.sql.SQLException: ORA-01435: user does not exist

This looks pretty straightforward, but as far as I can tell it really isn't.

  • I double checked the database properties several time by connecting to the DB with an external tool (Oracle SQLDeveloper).
  • I tried connecting with the schema owner and a second user (created for the web application), none of them work in the WLS data source (but both work perfectly in SQLDeveloper).
  • The same WLS instance can connect to a different Oracle data source without issues - it's just the new one that is making problems. (Also both the working and the non-working data source have the same managed server as their target.)

If I enter the exact same DB properties (host, port, driver, password) but change the username to a non-existing one I get a different error:

ORA-01017: invalid username/password; logon denied

So this tells me that somehow, the user does exist, but the WLS is still getting the ORA-01435 error.

Does anyone have an idea what the problem could be?

P.S. If I open the 'Monitoring' tab of the problematic data source the table is empty. So far I assumed this was because of the connection errors I'm getting, but I thought I'd mention it here anyway.

  • Does this user have the proper GRANTS to allow logins, SELECTS, etc from the WLS host? A connection from the WLS host vs your local machine could be the difference. – KM. May 6 '14 at 13:29
0

Was eventually able to figure out the problem:

The Weblogic Server defined an minuscule init SQL scriptlet that was executed on data source creation to test if the creation was successful. And it was actually this test SQL scriptlet, which was trying to access an inexistent user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.